Ask Your Question
0

package 'yaml-cpp' not found

asked 2015-10-13 11:13:40 -0600

yinkwongc gravatar image

updated 2015-10-13 13:04:21 -0600

gvdhoorn gravatar image

I am doing this exercise from below link

http://wiki.ros.org/nao/Tutorials/Ins...

After compile it, the command is below:

src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release -DCATKIN_ENABLE_TESTING=OFF -DCMAKE_INSTALL_PREFIX=~/my_workspace/ros_toolchain_install -j4

There are some error:

-- Found gtest: gtests will be built
-- Using Python nosetests: /usr/bin/nosetests-2.7
-- catkin 0.6.15
-- Boost version: 1.55.0
-- Found the following Boost libraries:
--   filesystem
-- checking for module 'yaml-cpp'
--   package 'yaml-cpp' not found
CMake Error at CMakeLists.txt:28 (if):
  if given arguments:

    "VERSION_GREATER" "0.5"

  Unknown arguments specified


-- Configuring incomplete, errors occurred!
<== Failed to process package 'camera_calibration_parsers': 
  Command '['/home/nao/nao_ros_ws/install_isolated/env.sh', 'cmake', '/home/nao/nao_ros_ws/src/image_common/camera_calibration_parsers', '-DCATKIN_DEVEL_PREFIX=/home/nao/nao_ros_ws/devel_isolated/camera_calibration_parsers', '-DCMAKE_INSTALL_PREFIX=/home/nao/nao_ros_ws/install_isolated', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']' returned non-zero exit status 1

Reproduce this error by running:
==> cd /home/nao/nao_ros_ws/build_isolated/camera_calibration_parsers && /home/nao/nao_ros_ws/install_isolated/env.sh cmake /home/nao/nao_ros_ws/src/image_common/camera_calibration_parsers -DCATKIN_DEVEL_PREFIX=/home/nao/nao_ros_ws/devel_isolated/camera_calibration_parsers -DCMAKE_INSTALL_PREFIX=/home/nao/nao_ros_ws/install_isolated -DCMAKE_BUILD_TYPE=Release -G 'Unix Makefiles'

Command failed, exiting.

I have already install yaml-cpp.

I have tried version 0.2.6 and 0.5.1 downloaded from below

https://code.google.com/p/yaml-cpp/do...

However, the errors are still happened. Can anyone help me to fix it? Thank You very much.

edit retag flag offensive close merge delete

Comments

Cross-post from here?

gvdhoorn gravatar imagegvdhoorn ( 2015-10-13 13:05:22 -0600 )edit

yes. It is..

yinkwongc gravatar imageyinkwongc ( 2015-10-13 21:22:20 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-03-19 16:41:12 -0600

Girts L gravatar image

I was getting "package 'yaml-cpp' not found" when building something else. I solved it by

sudo apt-get install libyaml-cpp-dev
edit flag offensive delete link more

Comments

#q60037 has CMakeLists.txt instructions

lucasw gravatar imagelucasw ( 2017-11-02 12:29:32 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-13 11:13:40 -0600

Seen: 3,941 times

Last updated: Mar 19 '16