Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

package 'yaml-cpp' not found

I am doing this exercise from below link

http://wiki.ros.org/nao/Tutorials/Installation/compileFromVirtualNao

After compile it, the command is below:

src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release -DCATKIN_ENABLE_TESTING=OFF -DCMAKE_INSTALL_PREFIX=~/my_workspace/ros_toolchain_install -j4

There are some error: -- Found gtest: gtests will be built -- Using Python nosetests: /usr/bin/nosetests-2.7 -- catkin 0.6.15 -- Boost version: 1.55.0 -- Found the following Boost libraries: -- filesystem -- checking for module 'yaml-cpp' -- package 'yaml-cpp' not found CMake Error at CMakeLists.txt:28 (if): if given arguments:

"VERSION_GREATER" "0.5"

Unknown arguments specified

-- Configuring incomplete, errors occurred! <== Failed to process package 'camera_calibration_parsers': Command '['/home/nao/nao_ros_ws/install_isolated/env.sh', 'cmake', '/home/nao/nao_ros_ws/src/image_common/camera_calibration_parsers', '-DCATKIN_DEVEL_PREFIX=/home/nao/nao_ros_ws/devel_isolated/camera_calibration_parsers', '-DCMAKE_INSTALL_PREFIX=/home/nao/nao_ros_ws/install_isolated', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']' returned non-zero exit status 1

Reproduce this error by running: ==> cd /home/nao/nao_ros_ws/build_isolated/camera_calibration_parsers && /home/nao/nao_ros_ws/install_isolated/env.sh cmake /home/nao/nao_ros_ws/src/image_common/camera_calibration_parsers -DCATKIN_DEVEL_PREFIX=/home/nao/nao_ros_ws/devel_isolated/camera_calibration_parsers -DCMAKE_INSTALL_PREFIX=/home/nao/nao_ros_ws/install_isolated -DCMAKE_BUILD_TYPE=Release -G 'Unix Makefiles'

Command failed, exiting.

I have already install yaml-cpp.

I have tried version 0.2.6 and 0.5.1 downloaded from below

https://code.google.com/p/yaml-cpp/downloads/list

However, the errors are still happened. Can anyone help me to fix it? Thank You very much.

package 'yaml-cpp' not found

I am doing this exercise from below link

http://wiki.ros.org/nao/Tutorials/Installation/compileFromVirtualNao

After compile it, the command is below:

src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release -DCATKIN_ENABLE_TESTING=OFF -DCMAKE_INSTALL_PREFIX=~/my_workspace/ros_toolchain_install -j4

-j4

There are some error: error:

-- Found gtest: gtests will be built
-- Using Python nosetests: /usr/bin/nosetests-2.7
-- catkin 0.6.15
-- Boost version: 1.55.0
-- Found the following Boost libraries:
--   filesystem
-- checking for module 'yaml-cpp'
--   package 'yaml-cpp' not found
CMake Error at CMakeLists.txt:28 (if):
  if given arguments:

arguments:

    "VERSION_GREATER" "0.5"

Unknown arguments specified

specified -- Configuring incomplete, errors occurred! <== Failed to process package 'camera_calibration_parsers': Command '['/home/nao/nao_ros_ws/install_isolated/env.sh', 'cmake', '/home/nao/nao_ros_ws/src/image_common/camera_calibration_parsers', '-DCATKIN_DEVEL_PREFIX=/home/nao/nao_ros_ws/devel_isolated/camera_calibration_parsers', '-DCMAKE_INSTALL_PREFIX=/home/nao/nao_ros_ws/install_isolated', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']' returned non-zero exit status 1

1 Reproduce this error by running: ==> cd /home/nao/nao_ros_ws/build_isolated/camera_calibration_parsers && /home/nao/nao_ros_ws/install_isolated/env.sh cmake /home/nao/nao_ros_ws/src/image_common/camera_calibration_parsers -DCATKIN_DEVEL_PREFIX=/home/nao/nao_ros_ws/devel_isolated/camera_calibration_parsers -DCMAKE_INSTALL_PREFIX=/home/nao/nao_ros_ws/install_isolated -DCMAKE_BUILD_TYPE=Release -G 'Unix Makefiles'

Makefiles' Command failed, exiting.

exiting.

I have already install yaml-cpp.

I have tried version 0.2.6 and 0.5.1 downloaded from below

https://code.google.com/p/yaml-cpp/downloads/list

However, the errors are still happened. Can anyone help me to fix it? Thank You very much.

package 'yaml-cpp' not found

I am doing this exercise from below link

http://wiki.ros.org/nao/Tutorials/Installation/compileFromVirtualNao

After compile it, the command is below:

src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release -DCATKIN_ENABLE_TESTING=OFF -DCMAKE_INSTALL_PREFIX=~/my_workspace/ros_toolchain_install -j4

There are some error:

-- Found gtest: gtests will be built
-- Using Python nosetests: /usr/bin/nosetests-2.7
-- catkin 0.6.15
-- Boost version: 1.55.0
-- Found the following Boost libraries:
--   filesystem
-- checking for module 'yaml-cpp'
--   package 'yaml-cpp' not found
CMake Error at CMakeLists.txt:28 (if):
  if given arguments:

    "VERSION_GREATER" "0.5"

  Unknown arguments specified


-- Configuring incomplete, errors occurred!
<== Failed to process package 'camera_calibration_parsers': 
  Command '['/home/nao/nao_ros_ws/install_isolated/env.sh', 'cmake', '/home/nao/nao_ros_ws/src/image_common/camera_calibration_parsers', '-DCATKIN_DEVEL_PREFIX=/home/nao/nao_ros_ws/devel_isolated/camera_calibration_parsers', '-DCMAKE_INSTALL_PREFIX=/home/nao/nao_ros_ws/install_isolated', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']' returned non-zero exit status 1

Reproduce this error by running:
==> cd /home/nao/nao_ros_ws/build_isolated/camera_calibration_parsers && /home/nao/nao_ros_ws/install_isolated/env.sh cmake /home/nao/nao_ros_ws/src/image_common/camera_calibration_parsers -DCATKIN_DEVEL_PREFIX=/home/nao/nao_ros_ws/devel_isolated/camera_calibration_parsers -DCMAKE_INSTALL_PREFIX=/home/nao/nao_ros_ws/install_isolated -DCMAKE_BUILD_TYPE=Release -G 'Unix Makefiles'

Command failed, exiting.

I have already install yaml-cpp.

I have tried version 0.2.6 and 0.5.1 downloaded from below

https://code.google.com/p/yaml-cpp/downloads/list

However, the errors are still happened. Can anyone help me to fix it? Thank You very much.