Ubuntu 14.04 package broken: tf2::BufferCore::_allFramesAsDot(double) const

asked 2015-10-07 04:54:18 -0600

oinkmaster2000 gravatar image

updated 2015-10-07 04:55:49 -0600

Hello all ,

It seems I updated to:

ros-indigo-desktop-full:
  Installed: 1.1.4-0trusty-20150913-1645-+0000
  Candidate: 1.1.4-0trusty-20150913-1645-+0000
  Version table:
 *** 1.1.4-0trusty-20150913-1645-+0000 0
        500 http://packages.ros.org/ros/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

Now I get the following error:

    /opt/ros/indigo/lib/libtf.so:
    undefined reference to
   `tf2::BufferCore::_allFramesAsDot(double)
    const'

It compiles on the previous version, but I cannot install this previous version on my machine anymore. >(

edit retag flag offensive close merge delete

Comments

PS: When I install ros from sources it works.

oinkmaster2000 gravatar image oinkmaster2000  ( 2015-10-07 15:16:28 -0600 )edit