Ask Your Question
0

How to change Hokuyo min and max angle values?

asked 2015-10-06 04:30:07 -0500

nightblue gravatar image

updated 2015-10-06 04:32:17 -0500

Hello everyone,

I have 40 Hz lidar Hokuyo UST-10LX and using in a custom robot. I successfully built a map using gmapping and amcl worked perfectly with this lidar.

My problem is about lidar configuration: Although I successfully used my lidar in amcl or gmapping, when I tried to set parameters using

param name="min_ang" type="double" value="-1.047"

param name="max_ang" type="double" value="1.047"

It seems it does not work. since After changed max and min angle values from above and I opened laser beams in rviz I still see same coverage in laser beams (i.e. Max and min angle DOESN'T CHANGE).

My Hokuyo launch file is as follows:

<launch> <node pkg="urg_node" type="urg_node" name="urg_node" respawn="false" output="screen">

</node>

How can I change the max and min angle values of Hokuyo 10 LX? Thanks..

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-10-06 05:00:04 -0500

dornhege gravatar image

According to the documentation the names of the parameters are angle_min and angle_max.

edit flag offensive delete link more

Comments

Thank you, I had directly used min_ang and max_ang by just looking the beginning of the documentation, but after your notice I discovered the true parameter name in middle of doc. I tried angle_min and max and now it works!

Thanks...

nightblue gravatar image nightblue  ( 2015-10-06 06:39:18 -0500 )edit

can you please specify where you changed those parameters.I am facing a similar problem!

Shashank_Rao gravatar image Shashank_Rao  ( 2017-05-27 06:30:12 -0500 )edit

Shashank_Rao: run rosrun rqt_reconfigure rqt_reconfigure opens a GUI to adjust the parameters.. If you wanna use the command line , use the rosparam command-line tool rosparam. Thanks

SpacemanSPIFF gravatar image SpacemanSPIFF  ( 2017-05-30 17:19:23 -0500 )edit

Thanks i solved it by changing the params in the .gazebo file of my robot so i guess that works as well

Shashank_Rao gravatar image Shashank_Rao  ( 2017-05-31 00:10:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-06 04:30:07 -0500

Seen: 1,866 times

Last updated: Oct 06 '15