USB Cam ImagingSource Problem

asked 2015-09-24 06:51:40 -0600

Tirgo gravatar image

updated 2015-09-24 07:35:16 -0600

Hello, I am currently trying to get the DMK 42BUC03 link_to_camera from ImagingSource to work with an ROS package.

I tried usb_cam:

[ERROR] [1443095249.460258490]: Webcam: expected picture but didn't get it...

I tried uvc_cam:

opening /dev/video0
pixfmt 0 = 'GREY' desc = 'Greyscale 8-bit (Y800)'
  discrete: 1280x960:   1/30 1/25 1/15 1/10 
  discrete: 720x480:   1/60 1/30 1/25 1/15 
  discrete: 640x480:   1/60 1/30 1/25 1/15 
  int (Gain, 0, id = 980913): 34 to 255 (1)
  int (Exposure (Absolute), 0, id = 9a0902): 1 to 300000 (1)
Segmentation fault (core dumped)

i tried the normal vlc player for ubuntu:

I get an image but it says:

[0x7fcd5401b198] main blend error: blending RGBA to GREY failed
[0x7fcd5401b198] blend blend error: no matching alpha blending routine (chroma: RGBA -> GREY)

The camera is set to uvc mode and it is an USB2.0 camera. It is detected correctly from my linux system. Thx for your help.

edit retag flag offensive close merge delete