Ask Your Question
2

Logitech webcams very "dark" when using uvc_cam

asked 2011-06-12 08:57:18 -0500

Tim gravatar image

updated 2014-01-28 17:09:50 -0500

ngrennan gravatar image

I am running into an issue with the exposure of my logitech webcams. After launching uvc_cam, either camera (logitech 1 or 2) only works properly after manually changing the camera using uvc_cam_node. If I have /dev/video1 in the camera.launch file, then switching it to /dev/video2 using the uvc_cam_node will make video2 work and vice versa. I am receiving a warning:

WARN [1307826164.686116661]: [camera] calibration does not match video mode (publishing uncalibrated data)

When I set it in dynamic_reconfigure and save the settings to a yaml file, it looks like this:

{absolue_exposure: 2089, brightness: 66, camera_info_url: '', camera_name: camera, contrast: 50, device: /dev/video2, exposure: 1, format_mode: 1, frame_id: /camera, frame_rate: 20.0, grain: 82, height: 240, power_line_frequency: 0, saturation: 50, sharpness: 142, white_balance_temperature: true, width: 320}

Best regards, Tim

edit retag flag offensive close merge delete

Comments

Which uvc_cam are you using? There are at least two different packages with that name. I suggest including the link to the source repo in your question. If it's my version of uvc_cam, I can definitely explain this behavior.
Eric Perko gravatar image Eric Perko  ( 2011-06-12 09:36:41 -0500 )edit
Hello Eric, I downloaded the package from this link: git clone https://github.com/ericperko?uvc_cam.git. Also, the model of webcam I am using is the Logitech QuickCam E 3560.
Tim gravatar image Tim  ( 2011-06-12 16:29:36 -0500 )edit

Hello Tim, I have downloaded the package form the link: git clone https://github.com/ericperko?uvc_cam.git. I want to know how to build it or make it, thanks

JennyLu gravatar image JennyLu  ( 2014-03-12 10:24:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-06-13 10:01:13 -0500

Eric Perko gravatar image

Okay. Two answers:

  1. The warning you show is perfectly normal if you actually have not yet calibrated your camera at the resolution you are currently running at (or you didn't save the calibration to a file).
  2. Due to the particular use case we originally forked the driver for, the defaults in the test launch file set the camera to be very "dark". What you will want to do is to create your own camera launch file that sets your parameters appropriately. The ones you will have to change to "undarken" the camera would either be absolute_exposure if you want to manually set the exposure to a fixed value, or change the exposure parameter to an automatic exposure setting. You'll have to play around with dynamic reconfigure to find the appropriate value (but for my Logitech Webcam Pro 9000, the only auto exposure it supports is "3"). I can't say exactly for certain what your webcam supports, but you can also play around with it in guvcview, which is a Linux tool that uses the same underlying driver interfacing (and so shares parameter constants).

Eventually I'd like to update the driver (maybe once an "official" USB camera driver is underway or as part of that work) to work more like camera1394, where it only changes out of the auto mode if you explicitly set the driver to use a manual value. I emphasize the eventually in there since I really need to write my M.S. thesis instead of work on a camera driver right now ;)

Hope that helps.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-06-12 08:57:18 -0500

Seen: 2,207 times

Last updated: Jun 13 '11