Ask Your Question
1

rosdep update error

asked 2015-08-17 22:14:55 -0600

lanxuedonghe gravatar image

updated 2015-08-18 01:30:42 -0600

ahendrix gravatar image

Hello, I'm installing ros hydro on ubuntu 12.04 in beaglebone black, the processor is ARMv7, the OS type is 32-bit. After running "sudo rosdep init" successed, when i run "rosdep update", it shows error as follows:

ubuntu@ubuntu-armhf:~$ rosdep update
reading in sources list data from /etc/ros/rosdep/sources.list.d
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml]:
 <urlopen error [Errno -2] Name or service not known> 
       (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml]:
        <urlopen error [Errno -2] Name or service not known> 
(https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml]:
        <urlopen error [Errno -2] Name or service not known> 
(https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml)
Hit https://raw.githubusercontent.com/ros/rosdistro/master/releases/fuerte.yaml
Query rosdistro index https://raw.github.com/ros/rosdistro/master/index.yaml
Add distro "groovy"
Add distro "hydro"
Add distro "indigo"
ERROR: error loading sources list:
        <urlopen error <urlopen error [Errno -2] Name or service not known> 
(https://raw.github.com/ros/rosdistro/master/indigo/distribution.yaml)>

And I run "which rosdep" & "rosdep --version" & "apt-cache policy python-rosdep", the result is:

ubuntu@ubuntu-armhf:~$ which rosdep
/usr/bin/rosdep
ubuntu@ubuntu-armhf:~$ rosdep --version
0.10.30
ubuntu@ubuntu-armhf:~$ apt-cache policy python-rosdep
python-rosdep:
Installed: 0.10.30-1
Candidate: 0.10.30-1
Version table:
 *** 0.10.30-1 0
500 http://packages.namniart.com/repos/ros/ precise/main armhf Packages
100 /var/lib/dpkg/status

Please help me do with these errors.

edit retag flag offensive close merge delete

Comments

I also have this error, anyone to help?

marcobecerrap gravatar imagemarcobecerrap ( 2016-05-16 11:16:44 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2015-08-18 01:43:03 -0600

ahendrix gravatar image

The error here is Name or service not known, which suggests that you don't have a network connection, or your DNS settings are incorrect.

Are you sure your network connection is working? Try ping www.google.com

edit flag offensive delete link more

Comments

He never gets a ping Google, it's blocked in China:D

artemiialessandrini gravatar imageartemiialessandrini ( 2019-11-01 05:26:40 -0600 )edit
1

answered 2017-02-28 02:25:39 -0600

melodybinbin gravatar image

It is the network issue on your end ,not ROS.Please check out your network,or change to another network.

edit flag offensive delete link more
0

answered 2018-01-18 19:33:24 -0600

Deepak Sharma gravatar image

I was getting the same error. My internet was working but I still got this timeout error. Maybe my internet was slow so tried few more times and it finally worked for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-17 22:06:22 -0600

Seen: 3,048 times

Last updated: Feb 28 '17