Ask Your Question
0

Rosaria P3-DX does not syn

asked 2015-08-17 09:56:30 -0600

End-Effector gravatar image

updated 2015-08-17 09:58:20 -0600

Hello,

I'm trying to use a P3-DX pionner, I installed ROSARIA. When I try to use rosrun the robot does not syn.

 

[ INFO] [1439822848.983522504]: RosAria: using port: [/dev/ttyUSB0]
Could not connect to simulator, connecting to robot through serial port /dev/ttyUSB0.
Syncing 0
No packet.
Syncing 0
No packet.
Trying to close possible old connection
Syncing 0
No packet.
Syncing 0
No packet.
 Robot may be connected but not open, trying to dislodge.
Syncing 0
No packet.
 Robot may be connected but not open, trying to dislodge.
Syncing 0
No packet.
Could not connect, no robot responding.
Failed to connect to robot.
[ERROR] [1439822855.737404764]: RosAria: ARIA could not connect to robot! (Check ~port parameter is correct, and permissions on port device.)
[FATAL] [1439822855.737519583]: RosAria: ROS node setup failed...

I've been checking several answers but so far no improvements. Any ideas on how to make this syn?

It's probably a port problem I don't understand how this PORT thing works. I used the command sudo chmod a+rw /dev/ttyUSB0 and after this rosrun rosaria RosAria _port:=/dev/ttyUSB0.

Thx so much.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2015-08-17 10:54:22 -0600

End-Effector gravatar image

I found the problem.

I had to EDIT the RosAria.cpp file.

In the file in the line 270 there is n.param("baud", serial_baud, 0); This needs to be changed to your robot's baud rate. In my casen.param("baud", serial_baud, 115200);

Then catkin_make.

Now it connects! Progress!

edit flag offensive delete link more

Comments

The third argument in the param method is a default value for a node parameter. In rosaria, 0 is used as a special case to let ARIA use its default value. See my answer below regarding setting the value of the baud parameter.

ReedHedges gravatar imageReedHedges ( 2015-08-19 09:42:04 -0600 )edit
1

answered 2015-08-19 09:39:11 -0600

ReedHedges gravatar image

updated 2015-08-19 09:39:32 -0600

You can supply the connection baud rate to rosaria as a parameter (~baud ). See the rosaria documentation at http://wiki.ros.org/ROSARIA/ (you don't need to edit the source code)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-17 09:56:30 -0600

Seen: 461 times

Last updated: Aug 19 '15