Ask Your Question
3

How to correctly reset time

asked 2015-08-12 06:42:18 -0500

Mehdi. gravatar image

updated 2015-08-27 09:44:21 -0500

I am using a bag in a loop because it is just convenient to keep the bag running and testing different algorithms. The problem is that once the bag starts from the beginning, my nodes using tf start printing out a lot of warnings about TF_OLD_DATA. To solve this, an empty message should be published to /reset_time.

I tried pushing the reset button in RVIZ but nothing happens and for example amcl complains about old tf data. Is there any solution to that problem?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-04 09:39:52 -0500

bergercookie gravatar image

You can use the --clock parameter in rosbag (e.g rosbag play --clock wg-cafe.bag). This way the TF buffer clears automatically on negative time.

See this as well: http://answers.ros.org/question/20674...

edit flag offensive delete link more

Comments

i am running this command only and nothing happens instead.i start gmapping slam_gmapping in one termonal and in other i start the rosbag play --clock file.bag. And nothing happen in the gmapping terminal, And error comes 100% messages dropped. I am using to record bag file of tf and scan in p3dx.

Dhagash Desai gravatar image Dhagash Desai  ( 2016-10-29 11:59:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-12 06:42:18 -0500

Seen: 3,214 times

Last updated: Aug 27 '15