Ask Your Question
1

allow_unknown parameter ignored

asked 2015-08-10 08:30:48 -0600

aau gravatar image

updated 2015-08-11 03:32:58 -0600

Hi there,

I want to avoid the global planner to plan its paths through the unknown because it is not working for my case. So as described here I set the paramter allow_unknown to false. So I created a yaml named global_planner.yaml file like this:

NavfnROS:
   allow_unknown: false
   default_tolerance: 5

In the launch file for the move_base node I added a line to load the parameters:

<node pkg="move_base" type="move_base" name="move_base" respawn="true">
   <rosparam file="$(find multi_robot_simulation)/config/global_planner.yaml" command="load" />
</node>

The parameter also shows up in the parameter server:

rosparam get /move_base/NavfnROS/allow_unknown

returns false, as expected. So, whats wrong here???

Thanks for any help! Micha

UPDATE:

I just pulled the navigation package from github to do some tests with the code. I realized the parameter is read just fine! The path planner still plans its path through unknown! Why??

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-08-11 04:23:38 -0600

aau gravatar image

updated 2015-08-11 04:38:05 -0600

I guess next time I should read the parameter description more carefully: http://wiki.ros.org/navfn?distro=indi...

The same issue has been described here: https://github.com/ros-planning/navig...

The parameter in question can be found here: http://wiki.ros.org/costmap_2d/hydro/...

edit flag offensive delete link more

Comments

Is this solved then?

David Lu gravatar imageDavid Lu ( 2015-08-11 17:26:51 -0600 )edit

Yes, but I cannot accept my own answer.

aau gravatar imageaau ( 2015-08-12 02:12:53 -0600 )edit
1

To make this a bit more than a link-only answer: The parameter description for allow_unknown that is linked above says: "if you are using a layered costmap_2d costmap with a voxel or obstacle layer, you must also set the track_unknown_space param for that layer to be true..."

Felix Widmaier gravatar imageFelix Widmaier ( 2018-02-19 10:13:03 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-10 08:30:48 -0600

Seen: 598 times

Last updated: Aug 11 '15