Unknown cell as a goal in Navigation stack with Gmapping [closed]

asked 2012-01-18 19:01:10 -0600

ParNurZeal gravatar image

updated 2014-01-28 17:11:09 -0600

ngrennan gravatar image

I know that there is already the question about this in How to set unknown pixel as goal in move_base. That question's owner successfully did it by not using static map. However, that means the robot will not use the updated map from Gmapping in navigating, it will use rolling windows as local_planner use. This is not the answer I want. I want the robot be able to really navigate to unknown cell with the map from Gmapping.

Some has suggested to set "navfn/allow_unknown" to true. I have already set it but the robot is still unable to compute a path to the unknown cell goal. I would be very appreciate if someone know how to do this. Thank you!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-09-09 15:09:38

Comments

I suffer from the same issue. I really don't get where the problem might be. I even looked at the code in gmapping that creates the map and it sets unknown areas to -1 (which is the same as 255 for unsigned 8 bit). navfn then checks for 255 and allow_unknown when it processes the map. it should work

Achim gravatar imageAchim ( 2012-08-29 21:51:59 -0600 )edit

Is there nobody using this combination? Or am I doing something wrong somewhere?

Achim gravatar imageAchim ( 2012-08-29 21:52:25 -0600 )edit

Hey PanNurZeal! Have you managed to accomplish it? I've tried using rolling windows and finally eliminate all errors but it doesn't create a path! I can view the unknown cells without a problem and can command the robot with proper path planning when using move_base_simple/goal as the navgoal topic

barrybear gravatar imagebarrybear ( 2013-06-26 00:41:26 -0600 )edit

Just to clarify, are you gmapping and doing navigation at the same time, with the map-being-created being used as the static_map in move_base?

David Lu gravatar imageDavid Lu ( 2013-06-26 05:48:11 -0600 )edit

Yeah I'm using GMapping and applying the navigation node at the same time. I've tried static_map = true for global costmap but it seems to be providing me with errors. But for static_map = false, no errors are found

barrybear gravatar imagebarrybear ( 2013-06-26 05:53:22 -0600 )edit

Maybe start up a new question so that you can provide more information.

David Lu gravatar imageDavid Lu ( 2013-06-26 07:11:08 -0600 )edit

Actually already did..but still stuck :( http://answers.ros.org/question/65564/how-to-navigate-to-unknown-space-in-costmap/ here's the link

barrybear gravatar imagebarrybear ( 2013-06-26 07:22:50 -0600 )edit

@barrybear, I have the same problem, please help if you have found an answer!

Gazer gravatar imageGazer ( 2013-06-27 13:10:59 -0600 )edit