Ask Your Question
3

catkin_make does not compile all packages in the workspace [closed]

asked 2015-08-03 23:45:40 -0600

webvenky gravatar image

updated 2015-08-04 04:17:04 -0600

I tried catkin_make from the workspace. It only finds one package in the workspace.. the rest dont get compiled.

~/catkin_ws$ catkin_make --force-cmake
Base path: /home/venky/catkin_ws
Source space: /home/venky/catkin_ws/src
Build space: /home/venky/catkin_ws/build
Devel space: /home/venky/catkin_ws/devel
Install space: /home/venky/catkin_ws/install
####
#### Running command: "cmake /home/venky/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/venky/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/venky/catkin_ws/install" in "/home/venky/catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/venky/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /home/venky/catkin_ws/devel;/home/venky/moveit/devel;/opt/ros/indigo
-- This workspace overlays: /home/venky/catkin_ws/devel;/home/venky/moveit/devel;/opt/ros/indigo
-- Using PYTHON_EXECUTABLE: /usr/bin/python
-- Using Debian Python package layout
-- Using empy: /usr/bin/empy
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/venky/catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- Using Python nosetests: /usr/bin/nosetests-2.7
-- catkin 0.6.9
-- BUILD_SHARED_LIBS is on
WARNING: Package "ompl" does not follow the version conventions. It should not contain leading zeros (unless the number is 0).
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 1 packages in topological order:
-- ~~  - fastmarching
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'fastmarching'
-- ==> add_subdirectory(fastmarching_node)
-- Using these message generators: gencpp;genlisp;genpy
-- fastmarching: 5 messages, 0 services
-- Configuring done
-- Generating done
-- Build files have been written to: /home/venky/catkin_ws/build
####
#### Running command: "make -j8 -l8" in "/home/venky/catkin_ws/build"
####
[  0%] [  0%] [  0%] Built target std_msgs_generate_messages_py
Built target std_msgs_generate_messages_lisp
Built target std_msgs_generate_messages_cpp
[  0%] [  0%] Built target _fastmarching_generate_messages_check_deps_pathFM
Built target _fastmarching_generate_messages_check_deps_dims
[  0%] [ 14%] Built target fmm_coverage
Built target _fastmarching_generate_messages_check_deps_InitAndGoal
[ 28%] [ 28%] Built target fmm_coverage_navn
Built target _fastmarching_generate_messages_check_deps_map
[ 28%] Built target _fastmarching_generate_messages_check_deps_pathTurtlebot
[ 42%] Built target test_nav_goals
[100%] [ 96%] [100%] Built target fastmarching_generate_messages_py
Built target fastmarching_generate_messages_lisp
Built target fastmarching_generate_messages_cpp
[100%] Built target fastmarching_generate_messages

The rest of the packages don't get compiled.

The ROS_PAKAGE PATH:

~/catkin_ws$ echo $ROS_PACKAGE_PATH 
/home/venky/catkin_ws/src:/home/venky/moveit/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks

I am not even able to rosrun the executables which got compiled before. I am using ROS after a break, I believe it has something to do with installing move_it.

~/catkin_ws$ catkin_make --pkg robot_setup_tf
Base path: /home/venky/catkin_ws
Source space: /home/venky/catkin_ws/src
Build space: /home/venky/catkin_ws/build
Devel space: /home/venky/catkin_ws/devel
Install space: /home/venky/catkin_ws/install
####
#### Running command: "make cmake_check_build_system" in "/home/venky/catkin_ws/build"
####
####
#### Running command: "make -j8 -l8" in "/home/venky/catkin_ws/build/ua_ros_p3dx/robot_setup_tf"
####
make[1]: *** No rule to make target `ua_ros_p3dx/robot_setup_tf/all'.  Stop.
make: *** [all] Error 2
Invoking "make" failed

The output for rospack profile:

$ rospack profile --length=2000
Full tree crawl took 0.032864 seconds.
Directories marked with (*) contain no manifest.  You may
want to delete these directories.
To get just of list of directories without manifests,
re-run the profile with --zombie-only
-------------------------------------------------------------
0.019945   /opt/ros/indigo/share
0.010117   /home/venky/catkin_ws/src
0.004896   /home/venky/catkin_ws/src/navigation
0.002051   /home/venky/moveit/src
0.001361   /home/venky/catkin_ws/src/turtlebot_simulator
0.001351   /home/venky/catkin_ws ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by webvenky
close date 2015-08-04 15:12:38.666126

Comments

In some cases rospack profile may help

Boris gravatar imageBoris ( 2015-08-04 03:49:22 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-08-04 13:34:58 -0600

William gravatar image

Based on the output you posted, it looks like the only package catkin_make is finding in your source space (/home/venky/catkin_ws/src) is called fastmarching. Yet you seem to be trying to build a package called robot_setup_tf based on your arguments to catkin_make. There must be something strange about your setup in your source space. Can you edit your question with the output of tree -L 3 /home/venky/catkin_ws/src?

My guess is that you have a package.xml which is blocking the other packages or something strange like that. I think this because you have /home/venky/catkin_ws/src/ua_ros_p3dx on your ROS_PACKAGE_PATH according to the output of rospack profile. This would allow rospack to find it, but would potentially mean catkin_make would not, since catkin_make just looks recursively in the source space, stopping when it finds a package.xml, and does not consider the ROS_PACKAGE_PATH.

edit flag offensive delete link more

Comments

Thanks William. I deleted the build and devel directories and tried recompiling. It works now. I dont know why it behaved so strange earlier.

webvenky gravatar imagewebvenky ( 2015-08-04 15:05:25 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-08-03 23:45:40 -0600

Seen: 6,021 times

Last updated: Aug 04 '15