ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Error when calling catkin_make --> Invoking "make" failed'

asked 2015-04-08 06:52:18 -0600

JamesAngsy gravatar image

updated 2015-04-08 15:33:39 -0600

William gravatar image


I'm new to ROS. I was following exactly the steps listed here:

However, when I run catkin_make, i got the following error:

user@ubuntu:~/catkin_ws$ catkin_make
Base path: /home/user/catkin_ws
Source space: /home/user/catkin_ws/src
Build space: /home/user/catkin_ws/build
Devel space: /home/user/catkin_ws/devel
Install space: /home/user/catkin_ws/install
#### Running command: "make cmake_check_build_system" in "/home/user/catkin_ws/build"
#### Running command: "make -j2 -l2" in "/home/user/catkin_ws/build"
[  3%] [  3%] Built target geometry_msgs_generate_messages_cpp
Generating dynamic reconfigure files from cfg/TurtleBot.cfg: /home/user/catkin_ws/devel/include/irobotcreate_node/TurtleBotConfig.h /home/user/catkin_ws/devel/lib/python2.7/dist-packages/irobotcreate_node/cfg/
../catkin_generated/ 16: exec: /home/user/catkin_ws/src/irobotcreate_node/cfg/TurtleBot.cfg: Permission denied
make[2]: *** [/home/user/catkin_ws/devel/include/irobotcreate_node/TurtleBotConfig.h] Error 126
make[1]: *** [irobotcreate_node/CMakeFiles/irobotcreate_node_gencfg.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[  3%] Built target diagnostic_msgs_generate_messages_cpp
make: *** [all] Error 2
Invoking "make" failed

How do I solve this?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2015-04-08 07:05:17 -0600

Wolf gravatar image

updated 2015-04-09 01:04:21 -0600

Add executable flag to the .cfg file:

cd /home/user/catkin_ws/src/irobotcreate_node/cfg/
chmod +x TurtleBot.cfg

Without the exec flag dynamic_reconfigure cannot created the reconfig headers....

edit flag offensive delete link more


Hi Wolf,

thanks for your reply. I did as you mentioned. but there's still error. The error is the same as above.

JamesAngsy gravatar image JamesAngsy  ( 2015-04-08 20:42:31 -0600 )edit

It works Wolf! thanks a lot! I changed to small cap 'x'.--> chmod +x TurtleBot.cfg

JamesAngsy gravatar image JamesAngsy  ( 2015-04-08 20:47:42 -0600 )edit

thanks, updated the answer:)

Wolf gravatar image Wolf  ( 2015-04-09 01:05:16 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2015-04-08 06:52:18 -0600

Seen: 10,079 times

Last updated: Apr 09 '15