Ask Your Question
4

Since updating ROS a few hours ago, ROS/catkin is broken

asked 2014-06-24 07:00:46 -0500

koenlek gravatar image

Hi all,

A couple of hours ago, I updated my system (sudo apt-get update; sudo apt-get upgrade). Updates included a lot of Hydro updates as well. However since then, catkin_make always ends in an error. I tried:

  • Reinstalling all ROS hydro packages
  • Rebooting computer
  • Create a new catkin ws and build the empty ws:
    • mkdir -p ~/catkin_ws/src
    • cd ~/catkin_ws/src
    • catkin_init_workspace
    • cd ~/catkin_ws/
    • catkin_make -> this gives an error again.
  • Commenting out all my ROS related stuff in .bashrc and try again with the new catkin ws in a new terminal

The relevant lines of the error seem to be (find full output of cmake_ here: https://www.dropbox.com/s/sgw9whjn2cm... ):

CMake Error at /home/koenlek/catkin_ws/build/catkin_generated/order_packages.cmake:2 (message):
  Invalid package manifest
  /opt/ros/hydro/lib/python2.7/dist-packages/qt_create/templates/qt-ros/package.xml":
  Package name "%(package)s does not follow naming conventions

  Invalid email %(author)s@gmail.com" for person "%(author)s""
Call Stack (most recent call first):
  /opt/ros/hydro/share/catkin/cmake/catkin_workspace.cmake:36 (include)
  CMakeLists.txt:63 (catkin_workspace)


-- Configuring incomplete, errors occurred!

I checked the qt-ros and qt-create packages, it seems like nothing has changed in the last apt-get update (no changes on their github at least), so I think it is something else causing the issues.

Anybody has any ideas how to fix this? I need to perform some tests later today, so I badly need my system to get up and running again.

It seems that answers.ros.org is experiencing some spamming spree with loads of non-sense spambot messages coming in the latest hours. Is this some hacking/ddos attempt that has caused the servers to serve me some non-working updates?

I run Ubuntu 12.04 x64 with latest updates.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-06-24 12:06:34 -0500

William gravatar image

The issue here is that catkin is now finding the "template" package.xml in the python directory for qt-create. I don't know if this is because qt-create recently moved it or because of a change in catkin, but either way, there needs to be a CATKIN_IGNORE file as a peer to the package.xml file which is giving you problems, so that catkin doesn't try to parse it.

edit flag offensive delete link more

Comments

Thanks. Adding CATKIN_IGNORE solved it too (but more nicely than my old way). Posted a bug report here: https://github.com/stonier/qt_ros/issues/10

koenlek gravatar image koenlek  ( 2014-06-25 10:58:49 -0500 )edit
0

answered 2014-06-24 08:26:29 -0500

koenlek gravatar image

I found a temporary fix, just edit this file: /opt/ros/hydro/lib/python2.7/dist-packages/qt_create/templates/qt-ros/package.xml and change all lines that are variables, e.g. %(author)s to normal strings, e.g. author.

I know that you should never modify files under the /opt/ros file hierarchy, but this was just an easy fix. The nicer way, which would likely work too, would be to locally install/compile qt_create/qt_ros by checking it out from github.

Still, this is of course not a satisfactory solution...

edit flag offensive delete link more

Comments

You should probably file a bug with either qt_create or catkin, so this gets sorted out. I'm not sure if the error lies in the faulty package template of qt_ros or in catkin parsing the template out of error.

AHornung gravatar image AHornung  ( 2014-06-24 08:30:12 -0500 )edit

I'll file a bug tomorrow. Thanks!

koenlek gravatar image koenlek  ( 2014-06-24 16:54:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-06-24 07:00:46 -0500

Seen: 1,295 times

Last updated: Jun 24 '14