Ask Your Question
0

Help with catkin_make on an ARM

asked 2013-02-06 16:23:03 -0500

AdrianPeng gravatar image

updated 2014-01-28 17:15:08 -0500

ngrennan gravatar image

Hi,

I am trying to install ROS packages from source on Gumstix Overo. And I created the catkin work space following this tutorial. Everything works.

Then I used git to download bondcore package to /catkin_ws/src directory.

Then I run "catkin_make" in /catkin_ws. This is output:

root@linaro-alip:~/catkin_ws# catkin_make 
lBase path: /root/catkin_ws
Source space: /root/catkin_ws/src
Build space: /root/catkin_ws/build
Devel space: /root/catkin_ws/devel
Install space: /root/catkin_ws/install
####
#### Running command: "make -j1" in "/root/catkin_ws/build"
####

It seems catkin cannot find bondcore to build.

Then I try to build bondcore without catkin_make following this tutorial. However, I got error while running "cmake ../src"

root@linaro-alip:~/catkin_ws/build# cmake ../src
-- Using CATKIN_DEVEL_PREFIX: /root/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /root/ros_core_ws/install
-- This workspace overlays: /root/ros_core_ws/install
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- catkin 0.5.52
-- BUILD_SHARED_LIBS is on
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing packages in topological order:
-- ~~  - beginner_tutorials
-- ~~  - bond
-- ~~  - bond_core
-- ~~  - smclib
-- ~~  - bondcpp
-- ~~  - bondpy
-- ~~  - test_bond
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ add_subdirectory(beginner_tutorials)
-- +++ add_subdirectory(bond_core-master/bond)
CMake Error at /root/ros_core_ws/install/share/catkin/cmake/catkinConfig.cmake:71 (find_package):
  Could not find a configuration file for package message_generation.

  Set message_generation_DIR to the directory containing a CMake
  configuration file for message_generation.  The file will have one of the
  following names:

    message_generationConfig.cmake
    message_generation-config.cmake

Call Stack (most recent call first):
  bond_core-master/bond/CMakeLists.txt:4 (find_package)


CMake Error at bond_core-master/bond/CMakeLists.txt:6 (add_message_files):
  Unknown CMake command "add_message_files".


-- Configuring incomplete, errors occurred!

Anyone know why this happened? Thanks in advance!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2013-02-06 16:38:16 -0500

WilliamWoodall gravatar image

You are asking to build the joy target, which doesn't exist. See:

####
#### Running command: "make -j1 joy" in "/root/catkin_ws/build"
####
make: *** No rule to make target `joy'.  Stop.
Invoking "make" failed

In stead of calling catkin_make joy simply call catkin_make and it will build everything in your workspace. In a new version of catkin_make (0.6.53+) there will be a --pkg option where you can specify individual packages from the workspace that you wish to build. See:

https://github.com/ros/catkin/pull/352

edit flag offensive delete link more

Comments

I tried both "catkin_make" and "catkin_make --pkg joy". Unfortunately, both of them didn't work. I updated the output.

AdrianPeng gravatar image AdrianPeng  ( 2013-02-06 16:51:46 -0500 )edit

catkin_make --pkg joy won't work until the next release of catkin... What is in your /catkin/src directory? It looks like there was nothing to build.

WilliamWoodall gravatar image WilliamWoodall  ( 2013-02-06 17:17:07 -0500 )edit

I download bondcore package from https://github.com/ros/bond_core to /catkin_ws/src. But catkin_make cannot find it. So I try to build bondcore without catkin_make, I got some errors which I updated in my question.

AdrianPeng gravatar image AdrianPeng  ( 2013-03-09 06:32:36 -0500 )edit
1

answered 2013-03-09 05:52:34 -0500

kalectro gravatar image

have a look at this tutorial There is also a SD card image with ROS preinstalled on that page

edit flag offensive delete link more

Comments

Hi kalectro, in my SD card image with ROS preinstalled, everything works except catkin_make. Is there any other way to solve this issue? Thanks.

AdrianPeng gravatar image AdrianPeng  ( 2013-03-09 06:47:31 -0500 )edit

Try catkin_make --force-cmake and make sure you have all package dependencies installed. Just downloading one package is usually not enough. Go to your src folder and do wstool merge http://packages.ros.org/web/rosinstall/generate/raw/groovy/bond_core; wstool update

kalectro gravatar image kalectro  ( 2013-03-09 07:10:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-06 16:23:03 -0500

Seen: 2,211 times

Last updated: Mar 09 '13