Ask Your Question
3

Boost error building catkin on OS X

asked 2013-02-22 17:07:44 -0500

Noldorin gravatar image

updated 2013-02-24 05:12:47 -0500

joq gravatar image

Running step 2.1.3 Building the catkin Workspace of http://www.ros.org/wiki/groovy/Installation/OSX/Homebrew/Source produces the following error (on OS X 10.8.2). It looks like it's a problem interfacing with BOOST?

[ 88%] Building CXX object CMakeFiles/draw_square.dir/tutorials/draw_square.cpp.o
usr/local/Cellar/boost/1.53.0/include/boost/type_traits/detail/has_binary_operator.hp:50: Parse error at "BOOST_JOIN"
make[2]: *** [include/turtlesim/moc_turtle_frame.cxx] Error 1
make[1]: *** [CMakeFiles/turtlesim_node.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Linking CXX executable /Users/alex/ros_catkin_ws/devel_isolated/turtlesim/lib/turtlesim/turtle_teleop_key
[ 88%] Built target turtle_teleop_key
Linking CXX executable /Users/alex/ros_catkin_ws/devel_isolated/turtlesim/lib/turtlesim/mimic
[ 88%] Built target mimic
Linking CXX executable /Users/alex/ros_catkin_ws/devel_isolated/turtlesim/lib/turtlesim/draw_square
[ 88%] Built target draw_square
make: *** [all] Error 2

<== Failed to process package 'turtlesim': 
  Command '/opt/ros/groovy/env.sh make -j8 -l8' returned non-zero exit status 2

Reproduce this error by running:
==> /opt/ros/groovy/env.sh make -j8 -l8

Command failed, exiting.

Any suggestions, people? Thanks in advance.

edit retag flag offensive close merge delete

Comments

I am using boost 1.49 on OSX, which is what I believe Groovy is build for, you can try that out but I am not sure if it will work ...

Hansg91 gravatar image Hansg91  ( 2013-02-23 04:34:30 -0500 )edit

@Hansg91: I could try that yeah, although I'd prefer the latest version of Boost be available (via brew) normally...

Noldorin gravatar image Noldorin  ( 2013-02-24 10:10:28 -0500 )edit

I seem to have isolated the error: <https://bugreports.qt-project.org/browse/QTBUG-22829>. Will report back soon!

Noldorin gravatar image Noldorin  ( 2013-02-24 10:47:58 -0500 )edit

Safer to use the boost version ROS was built and tested with.

joq gravatar image joq  ( 2013-02-25 05:02:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
4

answered 2013-02-25 05:10:05 -0500

William gravatar image

updated 2013-02-25 09:48:45 -0500

This has already been fixed in source:

https://github.com/ros/ros_tutorials/pull/6

UPDATE:

To get ros_tutorials from source into your workspace:

$ cd /path/to/your/workspace
$ rm -rf src/ros_tutorials src/roscpp_tutorials src/rospy_tutorials src/turtlesim
$ cd src
$ git clone https://github.com/ros/ros_tutorials.git
$ cd ..
$ catkin_make_isolated --install

That should get the ros_tutorials packages from source. (this may or may not work if there have been breaking changes in other packages which affect ros_tutorials)

edit flag offensive delete link more

Comments

Okay, that's great. How do I install from source though? Are their instructions parallel to the ones I linked to above?

Noldorin gravatar image Noldorin  ( 2013-02-25 09:23:54 -0500 )edit
1

You'll have to remove the packages affected from your workspace and fetch them from source instead. Currently there isn't any easy way to do this. I'll update my answer with instructions.

William gravatar image William  ( 2013-02-25 09:45:28 -0500 )edit

Thanks @William. I'll give that a go now and report back.

Noldorin gravatar image Noldorin  ( 2013-02-25 10:45:36 -0500 )edit

@William that might be the case with me. After I cloned ros_tutorials, I still got stuck at "Failed to process package 'roscpp_tutorials'". Removing the entire ros_tutorials worked it around. Then I cloned it again but same problem.

130s gravatar image 130s  ( 2013-03-25 01:56:36 -0500 )edit

It seems like @William's update moved the location of 'roscpp_tutorials' which causes the rebuild to fail. I had to 'rm -rf build_isolated' before running the build command for it to work. There is probably a less nuclear option, but that worked for me.

hawesie gravatar image hawesie  ( 2013-05-22 09:25:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-02-22 17:07:44 -0500

Seen: 1,278 times

Last updated: Feb 25 '13