Ask Your Question
0

catkin_make error

asked 2014-03-11 08:14:10 -0600

musik gravatar image

updated 2016-10-24 09:07:18 -0600

ngrennan gravatar image

I'm in the process of running catkin_make, but right before make is successful, I am receiving the following error with a gradle plugin:

:gradle_plugins:generatePomFileForMavenJavaPublication
:gradle_plugins:compileJava UP-TO-DATE
:gradle_plugins:compileGroovy UP-TO-DATE
:gradle_plugins:processResources UP-TO-DATE
:gradle_plugins:classes UP-TO-DATE
:gradle_plugins:jar UP-TO-DATE
:gradle_plugins:publishMavenJavaPublicationToMavenRepository
Uploading: org/ros/rosjava_bootstrap/gradle_plugins/0.1.18/gradle_plugins-0.1.18.jar to repository remote at file:/opt /ros/hydro/share/maven/
Transferring 91K from remote
/opt/ros/hydro/share/maven/org/ros/rosjava_bootstrap/gradle_plugins/0.1.18/gradle_plugins-0.1.18.jar (Permission denied)
:gradle_plugins:publishMavenJavaPublicationToMavenRepository FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ':gradle_plugins:publishMavenJavaPublicationToMavenRepository'.

    Failed to publish publication 'mavenJava' to repository 'maven'
    Error deploying artifact 'org.ros.rosjava_bootstrap:gradle_plugins:jar': Error deploying artifact: PUT request to: org/ros /rosjava_bootstrap/gradle_plugins/0.1.18/gradle_plugins-0.1.18.jar in remote failed

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 2.368 secs
make[2]: * [rosjava_bootstrap/CMakeFiles/gradle-rosjava_bootstrap] Error 1
make[1]:
[rosjava_bootstrap/CMakeFiles/gradle-rosjava_bootstrap.dir/all] Error 2
make: *
* [all] Error 2
Invoking "make" failed

Since the error mentioned permission being denied to the folder, I tried changing the permissions. I even used "chmod -R 777 filename(s)" but when I used catkin_make, I still received the same error.
Are there any possible workarounds or fixes for this issue? Any guidance would be greatly appreciated.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-03-11 19:51:01 -0600

Daniel Stonier gravatar image

It's trying to upload to file:/opt /ros/hydro/share/maven/ which indicates something is going wrong. catkin_make should only ever attempt to upload to your devel workspace (e.g. ~/my_workspace/devel/share/maven). Are your environment variables pointing to the right places? What does env | grep ROS show for you?

edit flag offensive delete link more

Comments

No my env. variables were not pointing to the correct places. I changed the ROS_MAVEN_PATH and ROS_MAVEN_DEPLOYMENT_REPOSITORY from /opt/ros/hydro/share/maven to ....../devel/share/maven using the export command, and my build was successful. Thanks!

musik gravatar imagemusik ( 2014-03-12 07:37:12 -0600 )edit

Hey musk, I am confronting the same error. Can you explain how you mean by saying I changed the ROS_MAVEN_PATH and ROS_MAVEN_DEPLOYMENT_REPOSITORY from /opt/ros/hydro/share/maven to ....../devel/share/maven

stevensu1838 gravatar imagestevensu1838 ( 2017-11-03 01:38:57 -0600 )edit
0

answered 2015-10-08 04:08:58 -0600

erikcong80 gravatar image

just go to catkin rosjava workspace and then source devel/setup.bash. It works for me

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-03-11 08:14:10 -0600

Seen: 1,714 times

Last updated: Oct 08 '15