Ask Your Question
0

Cannot install Ros Jade on ubuntu 15.04

asked 2015-07-26 19:23:59 -0600

rafaelsoares gravatar image

updated 2015-07-27 06:42:15 -0600

gvdhoorn gravatar image

I am trying to install the ROS Jade on my Raspberry Pi 2, which is with Ubuntu Mate 15.04 Vivid. I am getting the error :

E: Unable to locate package ros-jade-desktop-full

Here is all my steps:

rafael@rafael-desktop:~$ lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:    15.04
Codename:   vivid

rafael@rafael-desktop:~$ sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'

rafael@rafael-desktop:~$ sudo apt-key adv --keyserver hkp://pool.sks-keyservers.net --recv-key 0xB01FA116

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.KUSPjeCJ2O --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/fo0bar_ubuntu_rpi2.gpg --keyserver hkp://pool.sks-keyservers.net --recv-key 0xB01FA116
gpg: requesting key B01FA116 from hkp server pool.sks-keyservers.net
gpg: key B01FA116: public key "ROS Builder <rosbuild@ros.org>" imported
gpg: Total number processed: 1
gpg:               imported: 1

rafael@rafael-desktop:~$ sudo apt-get update

Ign http://ppa.launchpad.net vivid InRelease                        
Ign http://ports.ubuntu.com vivid InRelease                         
Get:1 http://packages.ros.org vivid InRelease [4,015 B]
Ign http://ports.ubuntu.com vivid-updates InRelease                            
Ign http://ports.ubuntu.com vivid-security InRelease
Ign http://ports.ubuntu.com vivid-backports InRelease
Get:2 http://ppa.launchpad.net vivid Release.gpg [316 B]
Get:3 http://ports.ubuntu.com vivid Release.gpg [933 B]
Get:4 http://ppa.launchpad.net vivid Release [15.1 kB]                     
Get:5 http://ports.ubuntu.com vivid-updates Release.gpg [933 B]                
Get:6 http://packages.ros.org vivid/main armhf Packages [4,842 B]              
Get:7 http://ports.ubuntu.com vivid-security Release.gpg [933 B]
Get:8 http://ports.ubuntu.com vivid-backports Release.gpg [933 B]              
Get:9 http://ports.ubuntu.com vivid Release [217 kB]
Get:10 http://ppa.launchpad.net vivid/main armhf Packages [9,787 B]
Get:11 http://ports.ubuntu.com vivid-updates Release [63.5 kB]                 
Get:12 http://ppa.launchpad.net vivid/main Translation-en [3,643 B]            
Get:13 http://ports.ubuntu.com vivid-security Release [63.5 kB]                
Get:14 http://ports.ubuntu.com vivid-backports Release [63.5 kB]          
Get:15 http://ports.ubuntu.com vivid/main armhf Packages [1,327 kB]       
Ign http://packages.ros.org vivid/main Translation-en_US   
Ign http://packages.ros.org vivid/main Translation-en      
Get:16 http://ports.ubuntu.com vivid/restricted armhf Packages [7,128 B]       
Get:17 http://ports.ubuntu.com vivid/universe armhf Packages [6,312 kB]        
Get:18 http://ports.ubuntu.com vivid/multiverse armhf Packages [112 kB]        
Get:19 http://ports.ubuntu.com vivid/main Translation-en [793 kB]              
Hit http://ports.ubuntu.com vivid/multiverse Translation-en                    
Hit http://ports.ubuntu.com vivid/restricted Translation-en                    
Get:20 http://ports.ubuntu.com vivid/universe Translation-en [4,456 kB]        
Get:21 http://ports.ubuntu.com vivid-updates/main armhf Packages [144 kB]      
Get:22 http://ports.ubuntu.com vivid-updates/restricted armhf Packages [28 B]  
Get:23 http://ports.ubuntu.com vivid-updates/universe armhf Packages [81.4 kB ...
(more)
edit retag flag offensive close merge delete

Comments

Many people is getting this error with Jade.

Javier V. Gómez gravatar imageJavier V. Gómez ( 2015-07-27 02:06:15 -0600 )edit

Have you thought about trying ubuntu snappy?

jacksonkr_ gravatar imagejacksonkr_ ( 2016-03-23 16:36:10 -0600 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2015-08-11 15:55:46 -0600

ahendrix gravatar image

As noted on the ARM Install Page, the builds of ROS Jade for ARM only support Ubuntu 14.04 (Trusty)

edit flag offensive delete link more

Comments

Any idea when support for 15.04 will be available?

Ben12345 gravatar imageBen12345 ( 2015-08-12 07:02:10 -0600 )edit
1

answered 2015-08-13 22:25:40 -0600

Ben12345 gravatar image

I managed to get ROS up and running on Ubuntu / Linaro 14.04, and get stable wifi. http://linuxcake.com/rpi2-ubuntu/ https://www.raspberrypi.org/forums/vi...

This was helpful for the wifi - https://wiki.debian.org/WiFi/HowToUse... ^ tried the same procedure to get wifi with Ubuntu trusty 14.04 and it still doesn't work... no idea why.

Ran into some problems with memory when i plugged a Hokuyo LiDAR in to the pi running Ubuntu Linaro though, it completely crashed. Was able to temporarily fix it by changing the memory limit with "sudo ulimit -a" etc etc, but this is temporary and only for that terminal instance. You can change the config files to make it permanent but i can't get it to work.

If you can get snappy core 14 point whatever that might work? not looked into it massively but the wifi set up process is a bit different and might actually work. (I'm assuming that like me you tried Ubuntu Mate because the Wifi actually without you having a PhD in networking with linux?)

Hope this is of some use to someone, i think i'm going to give up and wait until some progress is made with trusty 14.04 or someone rolls out a better one. I have some single board X64 computers that'l run full desktop ubuntu so it's not a massive drama for me. I just wanted ROS running on the Pi so i had an excuse to play with the kernel and get a Pi TFT running on a robot of some nature.

Good luck guys!

edit flag offensive delete link more
-1

answered 2015-07-28 13:13:25 -0600

duck-development gravatar image

Try first

  • sudo apt-get install ros-jade-desktop-base

Greet Anton

edit flag offensive delete link more

Comments

This doesn't work.

Ben12345 gravatar imageBen12345 ( 2015-08-11 13:19:51 -0600 )edit

Hi, i'm having a similar problem. All this could be avoided if ubuntu trusty had built in wifi support. I think it's down to this being ubuntu 15.04 rather than 14.04

Have you made any progress?

Ben

Ben12345 gravatar imageBen12345 ( 2015-08-11 13:21:01 -0600 )edit

Please, do not post answers that are not actually answers. You can write them as comments.

Javier V. Gómez gravatar imageJavier V. Gómez ( 2015-08-12 02:08:52 -0600 )edit

I gave a possible reason why its happening, which is now an answer. How is "sudo apt-get install ros-jade-desktop-base" an answer?!

Ben12345 gravatar imageBen12345 ( 2015-08-12 07:01:08 -0600 )edit

Oops, sorry this didn't go here. I thought I wrote it in another answer saying: "I am having the same problem". Actually, I am pretty sue I wrote there.

Javier V. Gómez gravatar imageJavier V. Gómez ( 2015-08-12 08:39:12 -0600 )edit
-1

answered 2016-04-26 15:29:07 -0600

LogicRos gravatar image

Hello!

Can I to install ROS Indigo on Ubuntu Mate for Raspberry??? Could you tell me if Ubuntu Mate have a core to run in real time??

edit flag offensive delete link more

Comments

1

This is not an answer, and you're actually asking two different questions. You should ask the question about being able to install ROS on Ubuntu Mate as a new question, and you should ask the question about real-time processing on Ubuntu Mate either here or on an Ubuntu-specific forum.

ahendrix gravatar imageahendrix ( 2016-04-26 16:20:58 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-26 19:23:59 -0600

Seen: 2,569 times

Last updated: Apr 26 '16