Ask Your Question
0

ROSARIA catkin_make error

asked 2015-07-16 13:49:25 -0600

ROS_Fan gravatar image

I am trying to install ROSARIA package in my laptop. I have been using Ubuntu 14.04 and using ROS indigo. I follow the tutorial How to use ROSARIA. But when I try to use catkin_make to build rosaria package I am getting the following error message.

traversing 1 packages in topological order:
- rosaria

+++ processing catkin package: 'rosaria'
==> add_subdirectory(rosaria)
Using these message generators: gencpp;genlisp;genpy
Boost version: 1.54.0
Found the following Boost libraries:
thread
rosaria: 1 messages, 0 services
Configuring done
Generating done
Build files have been written to: /home/fan/catkin_ws/build
Running command: "make -j4 -l4" in "/home/fan/catkin_ws/build"
Scanning dependencies of target geometry_msgs_generate_messages_cpp
Scanning dependencies of target std_msgs_generate_messages_cpp
Scanning dependencies of target _rosaria_generate_messages_check_deps_BumperState
Scanning dependencies of target rosaria_gencfg
[  0%] [ 16%] [ 16%] Built target std_msgs_generate_messages_cpp
Built target geometry_msgs_generate_messages_cpp
Generating dynamic reconfigure files from cfg/RosAria.cfg: /home/fan/catkin_ws/devel/include/rosaria/RosAriaConfig.h /home/fan/catkin_ws/devel/lib/python2.7/dist-packages/rosaria/cfg/RosAriaConfig.py
../catkin_generated/env_cached.sh: 16: exec: /home/fan/catkin_ws/src/rosaria/cfg/RosAria.cfg: Permission denied
make[2]: *** [/home/fan/catkin_ws/devel/include/rosaria/RosAriaConfig.h] Error 126
make[1]: *** [rosaria/CMakeFiles/rosaria_gencfg.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Scanning dependencies of target std_msgs_generate_messages_py
Scanning dependencies of target geometry_msgs_generate_messages_py
[ 16%] Built target std_msgs_generate_messages_py
[ 16%] Built target geometry_msgs_generate_messages_py
[ 16%] Built target _rosaria_generate_messages_check_deps_BumperState
make: *** [all] Error 2
Invoking "make -j4 -l4" failed
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
3

answered 2015-07-17 01:27:28 -0600

mgruhler gravatar image

This looks like the RosAria.cfg file is not exectuable. This is required for dynamic_reconfigure to work. So do a

chmod a+x /home/fan/catkin_ws/src/rosaria/cfg/RosAria.cfg

and try again.

edit flag offensive delete link more

Comments

Oops, my fault. I've now fixed it in the repository, anyone encountering this can pull from it again, or just manually fix it as in migs answer. Thanks!

ReedHedges gravatar imageReedHedges ( 2015-07-17 09:52:43 -0600 )edit

Thank you, now it works :)

ROS_Fan gravatar imageROS_Fan ( 2015-07-17 10:12:13 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-16 13:49:25 -0600

Seen: 834 times

Last updated: Jul 17 '15