ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

roslaunch not working

asked 2015-07-13 09:29:02 -0500

Salocin808 gravatar image


When trying to run

roslaunch turtlebot_teleop keyboard_teleop.launch

I am getting the following error:

[keyboard_teleop.launch] is neither a launch file in package [turtlebot_teleop] nor is [turtlebot_teleop] a launch file name 
The traceback for the exception was written to the log file

the file exists though and the whole installation before worked fine! I don't know where to look. Any ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-07-13 09:38:42 -0500

gvdhoorn gravatar image

Have you remembered to source /path/to/the/relevant/setup.bash file in your terminal? You have to do that for every new terminal again, unless you've configured your .bashrc to do it for you.

edit flag offensive delete link more


I configured my file to do it for me. It is really strange. I changed into my directory where the teleop.launch is located and ran

roslaunch keyboard_teleop.launch im getting following output:

Salocin808 gravatar image Salocin808  ( 2015-07-13 10:10:54 -0500 )edit


core service [/rosout] found ERROR: cannot launch node of type [turtlebot_teleop/turtlebot_teleop_key]: turtlebot_teleop ROS path [0]=/opt/ros/indigo/share/ros ROS path [1]=/opt/ros/indigo/share ROS path [2]=/opt/ros/indigo/stacks No processes to monitor shutti

Salocin808 gravatar image Salocin808  ( 2015-07-13 10:11:55 -0500 )edit

From your other questions I think you built the turtlebot pkgs from source, right? Is the workspace where you did that also sourced? Your (possibly truncated) error shows only the default paths, not a source workspace. If the 'turtlebot workspace' is not on the path, roslaunch can't find the pkgs.

gvdhoorn gravatar image gvdhoorn  ( 2015-07-14 01:42:22 -0500 )edit

Thanks! roslaunch seems to work now for bringup and communications. But I get the same error now when trying roslaunch openni_launch openni.launch ...

Salocin808 gravatar image Salocin808  ( 2015-07-15 02:56:13 -0500 )edit

Please add more detailed information (edit your question) on how you installed ROS (using the debs, completely from source, or just the turtlebot bits from source), how you catkin workspaces are layed out, how many you have and how you use them. Without that we can only guess at what is going on.

gvdhoorn gravatar image gvdhoorn  ( 2015-07-15 03:14:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-07-13 09:29:02 -0500

Seen: 6,379 times

Last updated: Jul 13 '15