ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

robot_pose_ekf is not active

asked 2015-06-30 07:54:22 -0500

osmancns gravatar image

hello ı need to use robot_pose_ekf to publish odom for gmapping. ı see my imu data but still robot_pose_ekf not active. I use static transform publisher imu to base_footprint. what ı should to do for that ?

this is my result of $ rosservice call /robot_pose_ekf/get_status:

status: Input:
 * Odometry sensor
   - is NOT active
   - received 0 messages
   - listens to topic /odom
 * IMU sensor
   - is active
   - received 5907 messages
   - listens to topic /imu_data
 * Visual Odometry sensor
   - is NOT active
   - received 0 messages
   - listens to topic 
 * Robot pose ekf filter
   - is NOT active
   - sent 0 messages
   - pulishes on topics /robot_pose_ekf/odom_combined and /tf

mine robot_pose_ekf launch file :

<node pkg="robot_pose_ekf" type="robot_pose_ekf" name="robot_pose_ekf">
  <param name="output_frame" value="odom"/>
  <param name="base_footprint_frame" value="base_footprint"/>
  <param name="freq" value="30.0"/>
  <param name="sensor_timeout" value="1.0"/>  
  <param name="odom_used" value="false"/>
  <param name="imu_used" value="true"/>
  <param name="vo_used" value="false"/>
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2015-07-03 02:56:57 -0500

osmancns gravatar image

ı solved this problem like this:

robot_pose_ekf package need a /odom message. only /imu_data message (UM7) not enough for this package.So you need to publish a/ odom message from another package. ı published /pose2D message with laser_Scan_matcher package and ı transformed it /odom message like that /pose2D ---> /odom.

and in the end, robot_pose_ekf is active now with /odom and /imu_data messages.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-06-30 07:54:22 -0500

Seen: 1,109 times

Last updated: Jul 03 '15