problem with navigation stack [closed]

asked 2015-06-29 18:31:51 -0600

RS gravatar image

The path gets planned, however the robot drifts away and the path is constantly corrected by the algorithm till I receive a fatal error that the robot is stuck in a position from which it cannot move.

The terminal in which rviz was run from gives the following error : "Invalid argument passed to canTransform argument source_frame in tf2 frame_ids cannot be empty"

Can somebody give me some direction to proceed in?

Thanks in advance!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by David Lu
close date 2015-06-30 11:49:37.279099

Comments

What OS/ROS distro? What algorithm/package? Real robot or simulation? Which robot? What does your launchfile look like? Some more details on the error?

The rviz error points to an empty frame_id in a msg that should be visualized, but I guess this shouldn't be the problem. Try hunting the msg down.

mgruhler gravatar imagemgruhler ( 2015-06-30 00:58:33 -0600 )edit

Actually, I believe you might be able to solve your problems without answering most of the questions asked in the previous comment. That doesn't change the fact that you need to provide more information. Apparently, you have problems with costmap configurations. Can you share the parameters you used

yigit gravatar imageyigit ( 2015-06-30 05:25:58 -0600 )edit

I am using ros hydro in ubuntu 12.04, The problem was with tf, and now it works fine.Sorry for not providing enough information when I asked the question.I will remember this from next time. Thanks for your inputs!

RS gravatar imageRS ( 2015-06-30 11:32:47 -0600 )edit

@RS can you please expalin how you solved the tf issue? WHat change did you do?

automate gravatar imageautomate ( 2016-01-23 21:18:12 -0600 )edit