Ask Your Question
1

rviz and stage tf timing issue in SimulatingOneRobot tutorial

asked 2011-03-17 06:22:02 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

When trying the SimulatingOneRobot tutorial for stageros there appears an error in RViz concerning the LaserScan Transform:

Transform [sender=/stageros] For frame [base_laser_link]: No transform to fixed frame [/odom]. TF error: [You requested a transform that is 900.000 miliseconds in the past, but the most recent transform in the tf buffer is 1800.000 miliseconds old. ]

I have an Ubuntu 10.04 and the ROS diamondback Desktop-full installation.

Has anyone else come across this issue?

edit retag flag offensive close merge delete

Comments

Did you set the parameter "use_simtime" to "true"? You can check this be typing "rosparam get use_simtime" into a terminal.
Sabrina gravatar imageSabrina ( 2011-03-17 08:18:48 -0500 )edit
The parameter is actually use_sim_time. Be sure to set it (e.g. rosparam set /use_sim_time true) before you launch any nodes.
mkoval gravatar imagemkoval ( 2011-03-17 09:48:42 -0500 )edit
Thank you for your ideas. I tried setting the /use_sim_time parameter to true, but unfortunately the issue remains. Do you know about rviz configuration? Somewhere it is expecting that tf each 900.000 and that is probably configurable
chcorbato gravatar imagechcorbato ( 2011-03-17 22:06:17 -0500 )edit
The reported error usually occurs when ROS time and Wall time don't match.. Did you try pressing rviz' "Reset" button? Sometimes this helps. Try running "rosrun tf tf_echo /base_laser_link /odom". This should show up the requested transform periodically - if available.
Sabrina gravatar imageSabrina ( 2011-03-17 22:18:24 -0500 )edit
I've tried the Reset button, then the LaserSacan becomes ok but just for a moment, then the error re-appears. And that state makes the RViz almost unresponsive. The tf_echo shows the requested tf is avaible with a periodicity of 1.000
chcorbato gravatar imagechcorbato ( 2011-03-17 22:45:56 -0500 )edit
Is the scan displayed without errors if you change the fixed frame of rviz to "/base_laser_link" ?
Sabrina gravatar imageSabrina ( 2011-03-17 23:45:26 -0500 )edit
Yes!! that made it. I changed the Fixed Frame to /base_laser_link in the RViz Global Options and the error dissapeared. You may post the answer to my question. Thank you very much Sabrina.
chcorbato gravatar imagechcorbato ( 2011-03-18 03:29:32 -0500 )edit
Unfortunately there seems to remain some issue with the LaserScan that when active makes RViz almost unresponsive, but that's another issue.
chcorbato gravatar imagechcorbato ( 2011-03-18 03:29:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-03-26 03:40:23 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

The problem is due to some issue with RViz and the Decay time for the Laser Scan display. I solved it setting it to 0, so only the latests reading are shown. As soon as you increase that value, RViz goes slower, at least in my machine, and almost freezes for the value of 100 given in the RViz configuration file provided in the stageros package (the one used in the tutorial)

edit flag offensive delete link more

Comments

This sounds like your machine can't keep up. For reference what is your CPU and graphics card?
tfoote gravatar imagetfoote ( 2011-03-26 06:55:10 -0500 )edit
I'm using a VMWare virtual machine on a MacBook Pro with two i5 2.53GHz CPU's dedicated and a NVIDIA GeForce GT 330M
chcorbato gravatar imagechcorbato ( 2011-03-26 22:20:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-17 06:22:02 -0500

Seen: 693 times

Last updated: Mar 26 '11