Ask Your Question
0

kinect xbox 360

asked 2015-06-23 08:37:53 -0500

Hello! There are many questions about kinect installation in ROS community and my question is not original in it. But... I would like to sum up my understanding about this problems by asking the question: Am I right that drivers of sensor "kinect xbox 360" model 1414 does NOT install to ubuntu 14.02 precise, Hydro distribution?

It is true that I am not UNIX guru and sometimes I can not think out how to modify commands likes experienced users. Anyway, I figured out that many manuals are outdated currently and the files are edited in the repositories. I meant the manuals: http://blog.ethanlim.net/2013/08/inst... , http://a-asvadi.ir/install-kinect-xbo... and etc.

Also, I can not understand theoretically the relation between Hydro distribution and the kinect driver. Is the relation there?

Pls, give me an advice what I can do for installation kinect xbox 360 driver or kinect for microsoft on ubuntu. It is possible to reinstall another ROS distribution and ubuntu version, if it will be needed.

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2015-06-24 02:06:09 -0500

Arowana gravatar image

updated 2015-06-24 20:08:47 -0500

I use ROS Indigo but I hope it works the same way for ROS Hydro You need to install freenect_stack package :

sudo apt-get install ros-hydro-freenect-stack

Then you should be able to launch the Kinect :

roslaunch freenect_launch freenect.launch

After this is launched you will be able to see topics related to the RGB, depth...

edit flag offensive delete link more
0

answered 2015-06-24 09:41:43 -0500

updated 2015-06-24 09:46:11 -0500

The command outputs the mistake that the package is not exist:

sudo apt-get install freenect_stack

But.. I was trying to read about freenect carefully and the package summary helped me : [ http://wiki.ros.org/freenect_stack ]

As result, I ran the simple image $ rosrun image_view image_view image:=camera/rgb/image_color , image distance measuring $ rosrun image_view disparity_view image:=camera/depth_registered/disparity and $ roslaunch freenect_launch freenect.launch sequentially. From this pic ( https://drive.google.com/folderview?i... ), it is clear that freenect_stack works with errors. Dont you know the reason of their emergency ?

edit flag offensive delete link more

Comments

Sorry it should be for the package name ros-hydro-freenect-stack because for me it is ros-indigo-freenect-stack. Yes it runs with errors but it works

Arowana gravatar imageArowana ( 2015-06-24 20:08:25 -0500 )edit

My problem is solved! I was following the advises In short,I reinstalled ubuntu and ROS to ubuntu 14.04 and Indigo distribution.As I have figured out that 64bit drivers didnt install to 32bit ubuntu)))foolish mista

dyupleks gravatar imagedyupleks ( 2015-06-27 01:53:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-06-23 08:37:53 -0500

Seen: 1,921 times

Last updated: Jun 24 '15