Ask Your Question
0

Install hector quadrotor on ROS Jade

asked 2015-06-22 12:32:54 -0600

RoboCop3d gravatar image

updated 2015-06-28 06:22:35 -0600

gvdhoorn gravatar image

I tried compiling the hector quadrotor files as according to the instructions given in the tutorials for hector quadrotor on the ROS page but the instruction catkin_make gives an Cmake Error! how do i overcome this?

Update: The CMake Error :

CMake Error at /opt/ros/jade/share/catkin/cmake/catkinConfig.cmake:75 (find_package):
  Could not find a package configuration file provided by
  "hardware_interface" with any of the following names:

    hardware_interfaceConfig.cmake
    hardware_interface-config.cmake

  Add the installation prefix of "hardware_interface" to CMAKE_PREFIX_PATH or
  set "hardware_interface_DIR" to a directory containing one of the above
  files.  If "hardware_interface" provides a separate development package or
  SDK, be sure it has been installed.
Call Stack (most recent call first):
  hector_quadrotor/hector_quadrotor_controller/CMakeLists.txt:7 (find_package)


-- Configuring incomplete, errors occurred!
edit retag flag offensive close merge delete

Comments

1

Please edit your question and paste in the CMake errors, so maybe someone can help you.

joq gravatar imagejoq ( 2015-06-22 17:26:55 -0600 )edit

Thanks for reminding me joq

RoboCop3d gravatar imageRoboCop3d ( 2015-06-25 14:52:10 -0600 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2015-06-28 04:03:41 -0600

l0g1x gravatar image

updated 2015-06-28 04:04:16 -0600

That means that you dont have the hardware_interface package. If you type pkg-config --list-all | grep hardware_interface it should be listed if it is installed. type this:

sudo apt-get install ros-jade-hardware-interface

i dont have a jade install with me right now so i cant double check, but if the above command doesnt work and apt-get says theres no such package, you'll need to try to install hardware_interface from source.

https://github.com/ros-controls/ros_c...

As a matter of a fact if you look at the wiki page for the package ( http://wiki.ros.org/hardware_interface ) jade doesnt show up yet as a distro, so youll need to install from source (make sure its the jade branch like the github link above)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-06-22 12:32:54 -0600

Seen: 1,741 times

Last updated: Jun 28 '15