hector_quadrotor rotates around goal point (dwa_local_planner) [closed]

asked 2021-03-17 06:40:58 -0500

TC gravatar image

I am fairly new to the ROS environment and have attempted to build a UAV system using the hector quadrotor following along this tutorial. I was largely successful in the 2D navigation of the UAV, the path planning to goals sent via RViz worked as expected and the UAV reached its goal without problem. However, when the UAV is positioned above z=10m, the navigation begins to act strange. It works fine until it approaches the goal point where it proceeds to circle around the goal without ever reaching the goal. The terminal outputs no warnings or errors.

I have used the ROS Navigation stack as seen in the tutorial and operate on a single computer using a virtual machine. I am using the ROS-Kinetic distro (I am aware that the distro is approaching its EOL). I have tried many of the answers to similar problems by other users but unfortunately nothing seemed to solve or improve the problem.

I have tried adjusting the goal and yaw tolerances as well as the distance_biases without any success. Any assistance would be greatly appreciated.

I unfortunately do not have enough karma to post an image of the settings I have used.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by TC
close date 2021-04-01 00:24:54.946416