Ask Your Question
0

problem with LaserScan in rviz

asked 2015-05-30 07:53:38 -0500

zeinab gravatar image

updated 2015-06-01 17:23:08 -0500

Hi, I have been using a depth_image_to_laserscan node to create a scan topic which I then use in gmapping and amcl. when I visualize the scan topic (even though hz of /scan in almost 30) it drops many messages when used in amcl but works perfectly with gmapping. I have checked the tf tree it is fine and the very same setting which works perfectly with gmapping has problems with amcl. My fixed frame is map in both cases. I tried changing the fixed frame to depth_image for amcl and it solved the problem. But I need to use it for navigation and I need my fixed frame to be /map. Could this be that map is not available at some instances of time and therefore the tf is not available (a message complaining about transform to depth_camera_link is not given is shown under the status of laserScan)? I also get a new error message complaining about canBus : Bus::open: Can not get ibus-daemon's address. But this is always issued but gmapping works fine. I have realized that amcl_pose is only published when I initialize the robot in rviz and apart from that there is nothing published to this topic. I also get this error in rviz for LaserScan for frame [/depth_camera_link]: No transfrom to fixed fram /map. Tf error:[lookup would require extrapolation into the future]

Sorry if it was too long. Thanks in advance for your help.

edit retag flag offensive close merge delete

Comments

Make sure you are sending an initial pose estimate with rviz when using amcl. Also you can edit your question rather than commenting to add information.

William gravatar image William  ( 2015-06-01 15:25:34 -0500 )edit

Thank you for your reply William. I already edited the question. I do send the initialpose to amcl. I have noticed a large delay (0.3 to 0.5) for odom to map tf when running tf_monitor. The odometery of my robot is good and scans also seem to match but amcl fails frequently to do proper localization

zeinab gravatar image zeinab  ( 2015-06-01 17:26:51 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-06-02 12:49:51 -0500

zeinab gravatar image

So Apparently the delay of \odom to \map was larger than the transform_tolerance of amcl and therefore it was dropping all the late tfs. I increased this parameter in my amcl. launch file and the problem is now solved.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-30 07:53:38 -0500

Seen: 1,393 times

Last updated: Jun 02 '15