Ask Your Question
0

Octomap dies with apparently no reasons...

asked 2015-05-30 03:04:09 -0600

Andromeda gravatar image

Hi guys, I cannot understand what is wrong with my pc. Octomap_server worked find and I had already a bit of experience with it. This morning I installed some packages like:

ros-indigo-octomap-mapping
ros-indigo-octomap-msgs
ros-indigo-octomap-rviz-pludings

and after that I cannot work with the package anymore.

I get all the time the following message:

[octomap_server-11] process has died [pid 20151, exit code -6, cmd /opt/ros/indigo/lib/octomap_server/octomap_server_node cloud_in:=my_cloud __name:=octomap_server __log:=/home/me/.ros/log/19ee9426-06a0-11e5-a24e-40167e2082be/octomap_server-11.log].
log file: /home/me/.ros/log/19ee9426-06a0-11e5-a24e-40167e2082be/octomap_server-11*.log

I don't get more infos than those. In my log file is just an incomplete sentence:

[ INFO] [1432972301.390171920]: Publishing latched (single publish will take longer, all topics are prepared)

Here is my launch file:

<launch>
  <!-- convert the scan data into sensor_msgs::pointCloud2 --> 
  <node pkg="laser_wrapper" type="scan_to_cloud" name="scan_to_cloud" >

    <remap from="scan" to="laser_scanner/laser/scan" />

  </node>

  <!-- run the octomap node to build map-->
  <node pkg="octomap_server" type="octomap_server_node" name="octomap_server" >

    <remap from="cloud_in" to="my_cloud" />

    <param name="resolution"              type="double" value=".05" />
    <param name="frame_id"                type="string" value="/odom" />
    <param name="base_frame_id"           type="string" value="/base_link" />
    <param name="sensor_model/max_range"  type="double" value="6.0" />
    <param name="height_map"              type="bool"   value="true" />
    <param name="occupancy_max_z"         type="double"  value="50.0" />

  </node>

</launch>

Even removing the last packages doesn't help, Removing octomap and installing it again doesn't help neither.

Ajain had a similar problem. But doesn't seem to be the case for me.

What should I do? Could be that I need to install everything from beginning?

Regards

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-05-31 02:08:47 -0600

Andromeda gravatar image

I realized, by checking the history in the linux shell, that the installation of the package: octomap-mapping did mess up somehow my system. Even all the rqt_* applications didn't run anymore.

I fixed this problem reinstalling completly from zero ROS. My package above worked without any change.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-30 03:04:09 -0600

Seen: 201 times

Last updated: May 31 '15