Ask Your Question
1

Problems using descartes package

asked 2015-05-12 09:31:04 -0500

bluefish gravatar image

updated 2015-06-22 10:23:16 -0500

Hi!

I would like to use the descartes-package and I'm facing some issues. I'm using an UR5 with the moveit- and universal_robot package and want use the descarts-package parallel to that. To achieve that I just copied the code of the descartes-tutorial in the existing c++-API and adjusted it for the UR5.

Until // 3. Create a planner and initialize it with our robot model everything seems to work fine, the robot model initialization seems to be okay but at // 4. Feed the trajectory to the planner I get errors.

[ INFO] [1431433577.983985044]: PreviousID: ID0 was not found
[ERROR] [1431433578.183296398]: Found 0 joint solutions out of 10 iterations
[ERROR] [1431433578.383429099]: Found 0 joint solutions out of 10 iterations
[ERROR] [1431433578.578341457]: Found 0 joint solutions out of 10 iterations
[ERROR] [1431433578.771480441]: Found 0 joint solutions out of 10 iterations
[ERROR] [1431433578.971189692]: Found 0 joint solutions out of 10 iterations
[ WARN] [1431433578.971260392]: Failed for find ANY joint poses, returning
[ INFO] [1431433578.971298149]: CartID: ID1 JointPoses count: 0
[ WARN] [1431433578.971329605]: no joint solution for this point... potential discontinuity in the graph
[ERROR] [1431433579.168980816]: Found 0 joint solutions out of 10 iterations

and so on until

[ERROR] [1431433587.831773855]: no joint solutions defined, thus no graph vertices
[ERROR] [1431433587.831796860]: unable to populate graph from input points
[ERROR] [1431433587.831822842]: Could not solve for a valid path

First I thought it's because it cannot reach the target pose, but I checked it for several poses which should be reachable and every time I get the same errors.

Does somebody know how I could solve this?

An additional question would be, whether the descartes-planner is considering the collision_scene of moveit?

Thanks and regards

EDIT: This is one of the trajectories I trying to reach. I think those could definitely be reached.

// 1. Define sequence of points
  TrajectoryVec points;
  for (unsigned int i = 0; i < 10; ++i)
  {
    Eigen::Affine3d pose;
    pose = Eigen::Translation3d(0.370 - 0.05 * i, -0.450, 0.675);
    descartes_core::TrajectoryPtPtr pt = makeTolerancedCartesianPoint(pose);
    points.push_back(pt);
  }
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-05-12 11:24:04 -0500

What kinematics plugin are you using? You can find this in the kinematics.yaml file inside the ur5 moveit config package used by your application.

edit flag offensive delete link more

Comments

I use the universal_robot-package and there in the file you described it says kdl_kinematics_plugin/KDLKinematicsPlugin

bluefish gravatar image bluefish  ( 2015-05-12 12:27:39 -0500 )edit

You could be running into some joint limits; these are set in the robots urdf file. Also, make sure that the tool orientation at those points in the example is reachable by your robot.

jrgnicho gravatar image jrgnicho  ( 2015-05-12 13:12:09 -0500 )edit

I think, the position I insert is inside the joint limits. In the tutorial, there is no orientation specified, so I did not specify anything either. However, the target position I insert should be reachable with q = 1.0 0.0 0.0 0.0, if that's the default value.

bluefish gravatar image bluefish  ( 2015-05-21 05:35:46 -0500 )edit
1

As written in this question already, I didn't try to hard to solve this as I found another solution for my problem. So don't strive to much helping me. Thanks @jrgnicho anyway for your support!

bluefish gravatar image bluefish  ( 2015-05-21 05:43:11 -0500 )edit
1

It's good that you found a solution. The UR5 robot could have it's tool oriented differently than the motoman arm used in the example. If this is the case then you'd have to apply an orientation offset to each pose so that it accommodates the orientation of the UR5 tip link.

jrgnicho gravatar image jrgnicho  ( 2015-05-21 13:05:11 -0500 )edit

Hi @jrgnicho. As I'd like to add another fuctionality to my system, I think I can only achieve with descartes, I'm again trying to get it to run. But still I have the same problem as mentioned above. I tried a lot of different pose-variations but still the same error. Could it be another problem?

bluefish gravatar image bluefish  ( 2015-06-22 10:15:55 -0500 )edit

@bluefish: please see if descartes/pull/126 affects your use case.

gvdhoorn gravatar image gvdhoorn  ( 2015-06-23 09:37:44 -0500 )edit

@bluefish, how are you validating the tool orientation?

jrgnicho gravatar image jrgnicho  ( 2015-06-25 15:44:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-05-12 09:31:04 -0500

Seen: 1,486 times

Last updated: Jun 22 '15