Ask Your Question
2

rviz don't follow the tf configuration of the .rviz file

asked 2015-05-05 11:17:01 -0600

updated 2015-05-05 11:17:53 -0600

Hello! My problem is that I want to display some of the TF and hide others. I can do it by selecting what I want by hand, but if I want to save it in a .rviz file and launching it with rosrun rviz rviz -d my_config.rviz, it display all my tf.

The .rviz file is well saved, here is an abstract of the /TF class in the my_config.rviz :

Visualization Manager:
Class: ""
  Displays:
    - Alpha: 0.5
      Cell Size: 1
      Class: rviz/Grid
      Color: 160; 160; 164
      Enabled: true
      Line Style:
        Line Width: 0.03
        Value: Lines
      Name: Grid
      Normal Cell Count: 0
      Offset:
        X: 0
        Y: 0
        Z: 0
      Plane: XY
      Plane Cell Count: 10
      Reference Frame: <Fixed Frame>
      Value: true
    - Class: rviz/TF
      Enabled: true
      Frame Timeout: 15
      Frames:
        All Enabled: false

            WheelFL_link:
              Value: false
            WheelFR_link:
              Value: false
            ar_marker_1:
              Value: true

"my_config.rviz" is the right one loaded ( I tried to add and remove a display type to be sure ), and I am using the rviz version 1.11.7 (indigo), Compiled against OGRE version 1.8.1 (Byatis).

edit retag flag offensive close merge delete

Comments

I have the same issue, no solution yet.

zweistein gravatar imagezweistein ( 2015-07-29 08:19:08 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-05-05 12:00:42 -0600

updated 2015-05-05 12:01:23 -0600

I've experienced this as well. This appears to be a bug: https://github.com/ros-visualization/... (rather, a bug report has been filed).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-05 11:17:01 -0600

Seen: 427 times

Last updated: May 05 '15