Ask Your Question
0

E: unable to locate package ros-indigo-desktop-full

asked 2015-04-29 12:14:55 -0600

tosandip gravatar image

I am getting the same error. I tried the 4 steps ( http://wiki.ros.org/indigo/Installati... ) and when I do :

sudo apt-get install ros-indigo-desktop-full

I get the error.

E: unable to locate package ros-indigo-desktop-full

When I check for the ros-latest.list, I get the following output:

....@ubuntu:~$ cat /etc/apt/sources.list.d/ros-latest.list 

deb http://packages.ros.org/ros/ubuntu vivid main

Let me know what might be going on.

I am running ubuntu 15.04 on vmware player

edit retag flag offensive close merge delete

Comments

you have done sudo apt-get update ?

inflo gravatar imageinflo ( 2015-04-29 12:45:09 -0600 )edit

Yes that passes without any errors.

tosandip gravatar imagetosandip ( 2015-04-29 13:50:45 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-04-29 14:30:06 -0600

updated 2015-04-29 14:30:51 -0600

As mentioned in step 1.2 of the page you linked

Setup your computer to accept software from packages.ros.org . ROS Indigo ONLY supports Saucy (13.10) and Trusty (14.04) for debian packages.

That means if you are using 15.04, you will need to build ROS from source.

edit flag offensive delete link more

Comments

1

Thanks for pointing this out. I am now trying to build ROS from source using the following link: http://wiki.ros.org/indigo/Installati...

This is failing at step 2.1.2

"could not have their rosdep keys resolved"

tosandip gravatar imagetosandip ( 2015-04-29 14:58:29 -0600 )edit
3

I think I am going to give up and install 14.04.2 which is supported.

tosandip gravatar imagetosandip ( 2015-04-29 15:11:23 -0600 )edit
0

answered 2017-01-19 02:46:59 -0600

niv gravatar image

You should make sure that the ROS version you are trying to install is compatible with your Ubunto vresion ( https://help.ubuntu.com/community/Che... )

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-29 12:14:55 -0600

Seen: 9,730 times

Last updated: Apr 29 '15