Ask Your Question
0

Kinect v2 "No devices connected..." I've tried everything.

asked 2015-04-12 15:13:23 -0500

divorce gravatar image

I'm at the point, I've tried literally everything for weeks now to get any kind of visualization and no dice because of No devices connected error.

I'm on an intel i7 w/ hd graphics 4k running ubuntu trusty 14.04lts trying to get visualization on ros indigo

First I tried getting it all to run in a virtual machine, I thought that was my big problem that Virtualbox would not recognize USB 3.0 devices. So I abandoned that and partitioned my drive & installed ubuntu. Went through a bunch of stuff trying to get openni and openni2 to work, eventually finding out that that is for the 360 device. So now I tried libfreenect2 & freenect but still can not get passed the no devices connected error.

My lsusb lists the kinect in 3 places as it should. I don't know where to go from here. I tried 'protonect' from libfreenect2 but I get an error about openCL on there.

Can someone walk me through it?

edit retag flag offensive close merge delete

Comments

When you download libfreenect2 there's a rules folder. Did you copy the file 90-kinect2.rules in your /etc/udev/rules.d/ folder ? You can run Protonect with cpu from the bin folder, to test if you can visualize the data :

./Protonect cpu
Cyril_J gravatar imageCyril_J ( 2015-05-28 08:30:09 -0500 )edit

I your Kinect a model 1473? If so this question may help you: http://answers.ros.org/question/196455/kinect-installation-and-setup-on-ros-updated/

luketheduke gravatar imageluketheduke ( 2015-12-19 14:13:10 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2015-04-12 16:45:55 -0500

marguedas gravatar image

updated 2015-04-12 16:51:20 -0500

Hi,

It seems that usb 3 is not well recognized on linux kernel < 3.13 so it doesn't work on every machine.

EDIT: try georg l answer before, this will tell you directly if you have a permission issue or if the problem is elsewhere. Otherwise here is how I sovled it on my laptop.

I've installed ubuntu14.04.2 which uses the newer kernel versions and kinect2 is working fine on it. I followed the steps listed here.

note: if you use 14.04.2, you'll need to install a bunch of X libraries, most of them are listed on the ROS installation page.
note2: the registration of the kinect2 point clouds is done on the computer, which take a huge amount of computing power, I'm trying to figure out how to make the GPU perform the registration. On an i7 laptop the framerate drops to 5~6 fps when you perform the registration.

edit flag offensive delete link more
2

answered 2015-04-12 16:41:35 -0500

georg l gravatar image

updated 2015-04-12 16:42:22 -0500

I had the same issue with a kinect v1 and the freenect stack. Try to change the permissions of the usb bus

 sudo chmod 777 -R /dev/bus/usb
edit flag offensive delete link more

Comments

This helped me with ubuntu mate 16.04.2 with ROS Kinetic on Raspbery pi 3. Thanks..

Imesh gravatar imageImesh ( 2018-01-22 10:54:19 -0500 )edit
0

answered 2015-06-22 22:42:10 -0500

updated 2015-06-22 22:43:30 -0500

You need to create a rule for your user in udev. Create a file named 90-kinect2.rules, put the following in it #

ATTR{product}=="Kinect2" SUBSYSTEM=="usb", ATTR{idVendor}=="045e", ATTR{idProduct}=="02c4", MODE="0666" SUBSYSTEM=="usb", ATTR{idVendor}=="045e", ATTR{idProduct}=="02d8", MODE="0666" SUBSYSTEM=="usb", ATTR{idVendor}=="045e", ATTR{idProduct}=="02d9", MODE="0666"

and save it in /etc/udev/rules.d. But do lsusb and make sure the id of your kinect corresponds to the ones above otherwise substitute the id's above with your kinect id. If you do copy it and all goes well, that should make you happy =)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-04-12 15:13:23 -0500

Seen: 3,164 times

Last updated: Jun 22 '15