Ask Your Question
0

Fovis_ros depth image format error

asked 2015-04-08 10:59:24 -0600

Athria gravatar image

Hello, I'm running ROS Hydro on Ubuntu 12.04 and trying to use the fovis_ros's mono_depth_odometer with a Kinect, but I'm facing the following problem:

First I tested the openni package with openni_launch enabling the depth_registration and verifying that it was publishing well both the rectified rgb and the depth images.

Then I saw there was a fovis_hydro_openni.launch file inside the fovis_ros folder and decided to try it, but it didn't work. I was getting the expected topics with no errors, but when I echoed them there were no messages coming from any of them; the odom → base_link tf was also not being published since the only tf was my base_link → camera (published with the static tf publisher).

I opted for making my own launch file, remapping the topics published by openni_launch to fit the requirements of fovis_ros. Here is the launch file (for some reason it didn't show up correctly when I pasted it here directly)

But after launching that file I got a Depth image must be in 32bit floating point format! error, here is the complete log.

I verified the documentation from openni_launch and the rgbd_launch and from what it says I think that the depth_registered/ sw_registered/ image_rect_raw topic is publishing the required rectify messages, since it calls depth_processing which converts uint16 to float.

The reason I'm using the sw_registered topic is because there is no rectified depth image topic under depth_register, there's only /camera/depth_registered/image_raw. Maybe I could use depth_image_proc on that topic, but openni_launch already uses the depth_processing, so it didn't seem logic.

Also, the fovis_ros package is still not publishing the expected tf, but maybe it's normal since I'm getting the depth image's error.

Thank you very much in advance.

edit retag flag offensive close merge delete

Comments

Hi,Irene. I run ROS indigo in ubuntu 1404 LTS. And I get a similar problem. If you have solve this problem. Could you help me? here Thanks first.

wsAndy gravatar imagewsAndy ( 2015-07-10 06:07:12 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-04-14 08:47:18 -0600

Miquel Massot gravatar image

Hi Athria,

if there's no depth, there won't be odometry, thus no tf. The driver expects depth registered images to work. In the launchfile for hydro and fovis, openni is missing. Provided that openni publishes to this topic below, it should work

$(arg camera)/depth_registered/sw_registered/image_rect_raw

check that you are running openni, and that you rectify the images. Check that the topic I just wrote has something. Then run the launchfile.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-08 10:59:24 -0600

Seen: 203 times

Last updated: Apr 14 '15