ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

ERROR: cannot launch node of type : can't locate node in package [closed]

asked 2015-04-07 23:57:12 -0500

hraza gravatar image

updated 2015-04-08 02:35:59 -0500

gvdhoorn gravatar image

Hello, Actually I am trying to launch the ardrone in simulator with the command roslaunch. I have ROS fuerte version on Ubuntu 12.04. Iam running the roslaunch command in the following directory /opt/ros/fuerte/stacks/ardrone_autonomy/launch.

I have typed this command in my terminal roslaunch ardrone.launch. But I get following error:

[roslaunch][ERROR] 2015-04-07 02:08:08,214: can't locate node [ardrone_driver] in package [ardrone_autonomy]
[roslaunch][ERROR] 2015-04-07 02:08:08,214: ERROR: cannot launch node of type [ardrone_autonomy/ardrone_driver]: can't locate node [ardrone_driver] in package [ardrone_autonomy]

Does I need to install ardrone_driver in ardrone_autonomy package. Thanks in advance for your help.

Does I need to connect a real drone with WIFI.

Please help me on this topic Iam totally blocked. Thanks alot. Regards, Hassan RAZA

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-08-28 03:13:47.469063


Did you do the following command: "source ~/catkin_package/devel/setup.bash" and "source /opt/ros/fuerte/setup.bash ?"

lilouch gravatar image lilouch  ( 2015-04-08 02:07:39 -0500 )edit

Thanks lilouch for your comment. Sorry for late reply Yes I have tried source /opt/ros/fuerte/setup.bash this command but the problem is not resolved.

hraza gravatar image hraza  ( 2015-04-15 22:55:17 -0500 )edit

I have discovered in repository /opt/ros/fuerte/stacks/ardrone_autonomy/src the ardrone_driver.h is missing. Probably the lake of this file is preventing to launch ardrone driver. as you can see the list of files that should be here

hraza gravatar image hraza  ( 2015-04-15 23:01:08 -0500 )edit

So it miss in your computer but not in github ? Try to download again the repo and reinstall it ?

lilouch gravatar image lilouch  ( 2015-04-15 23:07:52 -0500 )edit

Actually when I donwload ardrone_autonmy through github and I compile the files throguh rosmake I got an error. rosmake ] Built 97 packages with 1 failures.

hraza gravatar image hraza  ( 2015-04-16 01:45:41 -0500 )edit

is it possible to put ardrone_driver.h file through the graphic interface

hraza gravatar image hraza  ( 2015-04-17 04:00:37 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2015-04-16 01:41:54 -0500

hraza gravatar image

updated 2015-04-16 01:47:56 -0500

I am totally blocked not able to launch also the command roslaunch ardrone_tutorials keyboard_controller.launch. I got the same error. I have attached an error file if you can help me please. This error file contais all the detail. Please help me I have a presentation for final year project this error is blocking me unable to control niether through the keyboard, nor through joystick. Thanks in advance Hra

edit flag offensive delete link more

Question Tools


Asked: 2015-04-07 23:57:12 -0500

Seen: 4,014 times

Last updated: Apr 16 '15