Ask Your Question
0

Trouble building fovis_ros on Hydro [closed]

asked 2015-03-21 04:47:10 -0600

Athria gravatar image

Hello, I'm running Ubuntu 12.04 with ROS Hydro and wanted to test fovis_ros with a Kinect, but I'm having trouble building the package.

Following the advice given in this question I executed the following commands :

git clone https://github.com/srv/fovis.git

git clone https://github.com/srv/libfovis.git

So I had the fovis and libfovis folders inside catkin_ws/src.

Then I tried building with catkin_make and got the following messages at the end:

...
[ 98%] Built target fovis_ros_generate_messages
/home/ire/catkin_ws/src/fovis/fovis_ros/src/visualization.cpp:3:40: fatal error: libfovis/visual_odometry.hpp: No such file or directory
compilation terminated.
make[2]: * [fovis/fovis_ros/CMakeFiles/visualization.dir/src/visualization.cpp.o] Error 1
make[1]:
[fovis/fovis_ros/CMakeFiles/visualization.dir/all] Error 2
make: *
* [all] Error 2
Invoking "make" failed

I verified and the "visual_odometry.hpp" file is inside the libfovis/libfovis folder, like the rest of the files used by fovis_ros that don't seem to present an issue.

I tried building the libfovis library first, which gave no trouble and then adding fovis_ros but I got the exact same error. I also followed the advice from issue #11 but the problem remained.

Here is the complete log in case it's more useful.

Thank you in advance.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Miquel Massot
close date 2015-06-04 02:55:53.785190

Comments

1

Hi Athria, could you try to install ros-hydro-libfovis, remove libfovis from your workspace, delete build and devel directories and compile again?

Miquel Massot gravatar imageMiquel Massot ( 2015-03-24 05:14:34 -0600 )edit

Hello, than you! I tried that before installing libfovis from the git and I got errors, but I did it again (removing the libfovis, build and devel folders, then installing ros-hydro-libfovis an then catkin_make) but this is what I got.

Athria gravatar imageAthria ( 2015-03-24 06:52:29 -0600 )edit

Hello, I'm sorry, that was indeed the problem. I was selecting Hydro on the Branch scroll bar and then copying the clone URL on the right, but I guess it was not the way to do it; this time I downloaded the zip instead and it compiled without errors.

Thank you very much!

Athria gravatar imageAthria ( 2015-03-26 05:40:31 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-03-25 04:06:37 -0600

Miquel Massot gravatar image

updated 2015-03-26 10:02:37 -0600

Can you check if you are using hydro branch in fovis? Now our default is set on indigo.

You can simply switch the branch with "git checkout hydro".

edit flag offensive delete link more

Comments

Thank you! I was doing it wrong, now it compiles perfectly.

Athria gravatar imageAthria ( 2015-03-27 08:26:30 -0600 )edit

I am still facing the same problem. I installed libfovis via apt-get then I 'git clone' the repository and then checked out to hydro branch. but still I get this error

Sai Anirudh Kondaveeti gravatar imageSai Anirudh Kondaveeti ( 2015-05-26 23:37:19 -0600 )edit

Hello Sai, I don't know if it will help you but this is exactly what worked for me in the end: I deleted what I had from fovis, then I downloaded (manually, not by git clone) the two folders (libfovis and fovis) from the hydro branch in github to the catkin/src/ folder and then it compiled well.

Athria gravatar imageAthria ( 2015-05-27 05:18:54 -0600 )edit

I think when I was doing git clone it was downloading the indigo versions (I am really new with github) and that's why it wasn't working. I hope it helps

Athria gravatar imageAthria ( 2015-05-27 05:19:34 -0600 )edit

Thanks, but it didn't work for me.

Sai Anirudh Kondaveeti gravatar imageSai Anirudh Kondaveeti ( 2015-05-27 10:21:33 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2015-03-21 04:47:10 -0600

Seen: 403 times

Last updated: Mar 26 '15