Ask Your Question
1

weird logs when using tab completion on rosrun

asked 2015-03-11 07:23:28 -0600

Wolf gravatar image

updated 2015-03-11 10:01:06 -0600

Recently, I get some weird log messages when i try to complete the package name (or exec name) for rosrun using the tab key:

rosrun ro[OPTION]...: command not found
PATTERN: command not found
by: command not found
-i: command not found
The program 'and' is currently not installed. You can install it by typing:
sudo apt-get install and
PATTERN: command not found
PATTERN: command not found
PATTERN: command not found
PATTERN: command not found
No command 'use' found, did you mean:
 Command 'nse' from package 'ns2' (universe)
 Command 'ase' from package 'python-ase' (universe)
 Command 'fuse' from package 'fuse-emulator-sdl' (universe)
 Command 'fuse' from package 'fuse-emulator-gtk' (universe)
 Command 'muse' from package 'muse' (universe)
use: command not found
obtain: command not found
ignore: command not found
No command 'force' found, did you mean:
 Command 'forge' from package 'snap' (universe)
 Command 'zforce' from package 'gzip' (main)
force: command not found
No command 'force' found, did you mean:
 Command 'zforce' from package 'gzip' (main)
 Command 'forge' from package 'snap' (universe)
force: command not found
a: command not found
suppress: command not found
bash: syntax error near unexpected token `newline'

If I enter a fully qualified name rosrun is still working! Also auto completion is still working for roslaunch. Any ideas what could cause this??

Under Ubuntu 14.04.2 ROS indigo....

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-03-20 03:55:33 -0600

Wolf gravatar image

By comparing my during the installation modified ~/.bashrc with /etc/skel/.bashrc using diff I found that I accidentally inserted some characters behind a grep alias in the ~/.bashrc:

That's how it was, which caused the autocompletion error:

alias grep='grep --color=auto'accidentally inserted characters

That's how it now is and should be:

alias grep='grep --color=auto'

Apparently the autocompletion for rosrun somehow uses this alias which caused the failure...

edit flag offensive delete link more
0

answered 2015-03-12 13:00:19 -0600

tfoote gravatar image

It looks like something inside your rosrun autocompletion scripts are providing an error output instead of the result. There is either an error in one of your rosbash scripts or possibly a missing subcommand, or changed usage providing a help feedback instead of a list of commands.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-11 07:23:28 -0600

Seen: 408 times

Last updated: Mar 20 '15