ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
1

pointcloud_to_laserscan catkin_make fail

asked 2015-03-09 14:08:01 -0500

I'm am trying to utilize the Microsoft Kinect for navigation. I am utilizing ROS Hydro on Ubuntu 12.04.

I have not figured out how to use the navigation stack yet, so if you have any pointers on that, send them my way.

I have noticed that most of the navigation packages require /laserscan rather than/pointcloud2, so I have begun to try to get pointcloud_to_laserscan up and running.

I downloaded the package utilizing:

git clone https://github.com/ros-perception/perception_pcl.git

but when I ran catkin_make I received the following error:

CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:75 (find_package):
  Could not find a configuration file for package tf2_sensor_msgs.

  Set tf2_sensor_msgs_DIR to the directory containing a CMake configuration
  file for tf2_sensor_msgs.  The file will have one of the following names:

    tf2_sensor_msgsConfig.cmake
    tf2_sensor_msgs-config.cmake

Call Stack (most recent call first):
  perception_pcl/pointcloud_to_laserscan/CMakeLists.txt:4 (find_package)



CMake Error at perception_pcl/pcl_ros/CMakeLists.txt:5 (find_package):
  Could not find module Findcmake_modules.cmake or a configuration file for
  package cmake_modules.

  Adjust CMAKE_MODULE_PATH to find Findcmake_modules.cmake or set
  cmake_modules_DIR to the directory containing a CMake configuration file
  for cmake_modules.  The file will have one of the following names:

    cmake_modulesConfig.cmake
    cmake_modules-config.cmake

-- Configuring incomplete, errors occurred!
make: *** [cmake_check_build_system] Error 1
Invoking "make cmake_check_build_system" failed

I'm relatively new at this. Any thoughts?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-03-09 14:23:22 -0500

paulbovbel gravatar image

updated 2015-03-09 14:24:36 -0500

This is because you cloned the repo, but did not install any dependencies. To install dependencies you would run:

rosdep install --from-paths src --ignore-src --rosdistro hydro -y

Incidentally you cloned the indigo-devel branch by default, which will not work on hydro.

Why not just install the binaries via apt-get? This will pull in all dependencies automatically:

sudo apt-get install ros-hydro-pointcloud-to-laserscan

edit flag offensive delete link more

Comments

Good question...

sudo apt-get worked just fine.

Thanks.

sealguy77 gravatar imagesealguy77 ( 2015-03-09 15:52:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-03-09 14:08:01 -0500

Seen: 382 times

Last updated: Mar 09 '15