Ask Your Question
0

Trouble connecting Kinect with freenect_launch

asked 2015-03-09 13:26:52 -0500

frlevesque gravatar image

updated 2015-03-09 15:21:15 -0500

I am trying to connect to a Kinect model 1414 using freenect_launch and encountering a malloc(): memory corruption error (the full error log is listed below). I am running the program on Ubuntu 14.04 and ROS Indigo. I tried amongst other things installing the Avin2 drivers and the answers from http://answers.ros.org/question/19645... . I believe that freenect works since I can see the image coming from the Kinect using $freenect-glview. The error may come from a bad installation on my part since a "clean" install of freenect_launch on a another computer works.

$roslaunch freenect_launch freenect.launch
started roslaunch server http://

(...)

Ccore service [/rosout] found
process[camera/camera_nodelet_manager-1]: started with pid [2585]
[ INFO] [1425922185.882803329]: Initializing nodelet with 4 worker threads.
process[camera/driver-2]: started with pid [2606]
process[camera/debayer-3]: started with pid [2622]
process[camera/rectify_mono-4]: started with pid [2639]
process[camera/rectify_color-5]: started with pid [2653]
process[camera/rectify_ir-6]: started with pid [2667]
[ INFO] [1425922186.763444930]: Number devices connected: 1
[ INFO] [1425922186.764054940]: 1. device on bus 000:00 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A00365922188050A'
[ INFO] [1425922186.765529829]: Searching for device with index = 1
process[camera/depth_rectify_depth-7]: started with pid [2693]
[ INFO] [1425922186.869548788]: Starting a 3s RGB and Depth stream flush.
[ INFO] [1425922186.879730800]: Opened 'Xbox NUI Camera' on bus 0:0 with serial number 'A00365922188050A'
process[camera/depth_metric_rect-8]: started with pid [2730]
[ WARN] [1425922187.014798848]: Could not find any compatible depth output mode for 1. Falling back to default depth output mode 1.
[ INFO] [1425922187.050729900]: rgb_frame_id = '/camera_rgb_optical_frame' 
[ INFO] [1425922187.050813759]: depth_frame_id = '/camera_depth_optical_frame' 
[ WARN] [1425922187.090608470]: Camera calibration file /home/frlev142/.ros/camera_info/rgb_A00365922188050A.yaml not found.
[ WARN] [1425922187.091040185]: Using default parameters for RGB camera calibration.
[ WARN] [1425922187.091307200]: Camera calibration file /home/frlev142/.ros/camera_info/depth_A00365922188050A.yaml not found.
[ WARN] [1425922187.091539703]: Using default parameters for IR camera calibration.
process[camera/depth_metric-9]: started with pid [2797]
process[camera/depth_points-10]: started with pid [2826]
process[camera/register_depth_rgb-11]: started with pid [2855]
process[camera/points_xyzrgb_sw_registered-12]: started with pid [2872]
process[camera/depth_registered_rectify_depth-13]: started with pid [2900]
*** Error in `/opt/ros/indigo/lib/nodelet/nodelet': malloc(): memory corruption: 0x00000000008405f0 ***
[FATAL] [1425922188.084200848]: Service call failed!
close failed in file object destructor:
sys.excepthook is missing
lost sys.stderr
[FATAL] [1425922188.104229427]: Service call failed!**
process[camera/points_xyzrgb_hw_registered-14]: started with pid [2974]
[camera/camera_nodelet_manager-1] process has died [pid 2585, exit code -6, cmd /opt/ros/indigo/lib/nodelet/nodelet manager __name:=camera_nodelet_manager __log:=/home/frlev142/.ros/log/987a40be-c678-11e4-902f-0019d179e4f3/camera-camera_nodelet_manager-1.log].                                                      
log file: /home/frlev142/.ros/log/987a40be-c678-11e4-902f-0019d179e4f3/camera-camera_nodelet_manager-1*.log                                                  
process[camera/disparity_depth-15]: started with pid [3021]

Followed by a list of nodelets which did or did not launch successfully.

Any help would be appreciated!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-03-10 09:57:47 -0500

frlevesque gravatar image

Well, the nuclear option worked... I uninstalled Avin2 driver as well as ROS completely

$sudo apt-get purge ros-*

I then re-installed ROS. After that, I did a clean install of freenect_launch :

$sudo apt-get install libfreenect-dev

$sudo apt-get install ros-indigo-freenect-launch

The package was then able to launch without problem.

edit flag offensive delete link more

Comments

Hey, when i launch the freenect.launch file. it stops at [ INFO] [1426292123.259011990]: Stopping device RGB and Depth stream flush. I dont know what the problem is

dmngu9 gravatar imagedmngu9 ( 2015-03-13 19:18:41 -0500 )edit

Same issue here. It seems to not be able to get the depth data. Why? I have no idea.

ThaHypnotoad gravatar imageThaHypnotoad ( 2015-04-17 02:09:52 -0500 )edit

nvm. the warnings dont seem to have any effect on operation, and its supposed to stop at that line it seems dmngu9.

ThaHypnotoad gravatar imageThaHypnotoad ( 2015-04-17 22:34:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-09 13:26:52 -0500

Seen: 3,272 times

Last updated: Mar 10 '15