Ask Your Question
2

Octomap Self-filtering

asked 2015-03-04 10:54:14 -0500

rcj1986 gravatar image

updated 2016-02-05 03:39:07 -0500

130s gravatar image

Hi, I'm using UR5 moveit model with a kinect. I followed this tutorial

http://docs.ros.org/hydro/api/pr2_mov...

to add the kinect like a sensor. I add some parameter to do a self robot filter, but when I launch the robot model (roslaunch ur5_moveit_config demo.launch) I get the next error:

[ERROR] [1425487423.826931655]: Transform error: Lookup would require extrapolation into the future.  Requested time   1425487423.780933888 but the latest data is at time 1425487423.751322031, when looking up transform from frame   [forearm_link] to frame [camera_rgb_optical_frame]
[ERROR] [1425487423.827004659]: Transform cache was not updated. Self-filtering may fail.

Anyone know how to solve it?

Thanks.

This is my yaml file:

sensors:
  - sensor_plugin: occupancy_map_monitor/PointCloudOctomapUpdater
    point_cloud_topic: /camera/depth_registered/points
    max_range: 5.0
    point_subsample: 1
    padding_offset: 0.1
    padding_scale: 1.0
    filtered_cloud_topic: filtered_cloud
edit retag flag offensive close merge delete

Comments

where's the error message?

charkoteow gravatar image charkoteow  ( 2015-03-05 01:57:17 -0500 )edit

Edited question.

rcj1986 gravatar image rcj1986  ( 2015-03-05 05:05:53 -0500 )edit

Have you rectified it???

R@m gravatar image R@m  ( 2017-05-22 05:13:01 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-05-25 02:11:35 -0500

R@m gravatar image

I faced the same issue while using a depth camera with Mico2 arm. Solved it by following this thread.

I had to remove my binary installation of moveit and use a source version to modify the changes. Eventually, the source codes and header files are already modified in their rep. Additionally, you need to modify your planning_context.launch file and add the wait time as mentioned here.

edit flag offensive delete link more

Comments

I was facing the same error while working with intel real-sense depth camera and with my 5DOF arm.

Modified below lines to moveit_config/launch/planning_context.launch file solves problem as suggested by @R@m,

  <group ns="$(arg robot_description)_planning">
    <param name="shape_transform_cache_lookup_wait_time" value="0.1" />
    <rosparam command="load" file="$(find thorp_moveit_config)/config/joint_limits.yaml"/>
  </group>
askkvn gravatar image askkvn  ( 2020-05-08 07:44:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-04 10:54:14 -0500

Seen: 1,080 times

Last updated: May 25 '17