ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
7

Ubuntu 14.04.2 unmet dependencies (similar for 14.04.3)

asked 2015-02-23 09:46:47 -0500

NLZ gravatar image

updated 2015-08-31 06:55:06 -0500

demmeln gravatar image

I made a fresh install of Ubuntu 14.04.2 and I cannot install ros-indigo-desktop-full, because I get these errors:

The following packages have unmet dependencies:
 libcheese-gtk23 : Depends: libclutter-gtk-1.0-0 (>= 0.91.8) but it is not going to be installed
                   Depends: libcogl15 (>= 1.15.8) but it is not going to be installed
 libcheese7 : Depends: libclutter-gst-2.0-0 (>= 0.10.0) but it is not going to be installed
              Depends: gstreamer1.0-clutter but it is not going to be installed
 libclutter-1.0-0 : Depends: libcogl-pango15 (>= 1.15.8) but it is not going to be installed
                    Depends: libcogl15 (>= 1.15.8) but it is not going to be installed

Tried aptitude, that gives me these conflicts:

The following packages have unmet dependencies:
 libfltk1.1-dev : Conflicts: libfltk-dev which is a virtual package.
 libgl1-mesa-dri-lts-utopic : Conflicts: libgl1-mesa-dri but 10.1.3-0ubuntu0.3 is to be installed.
 libgl1-mesa-glx-lts-utopic : Conflicts: libgl1 which is a virtual package.
                              Conflicts: libgl1-mesa-glx but 10.1.3-0ubuntu0.3 is to be installed.
 xserver-xorg-lts-utopic : Conflicts: libgl1-mesa-dri (>= 0~) but 10.1.3-0ubuntu0.3 is to be installed.
                           Conflicts: libgl1-mesa-glx (>= 0~) but 10.1.3-0ubuntu0.3 is to be installed.
                           Conflicts: libglapi-mesa (>= 0~) but 10.1.3-0ubuntu0.3 is to be installed.
 libfltk1.3-dev : Conflicts: libfltk-dev which is a virtual package.
 libgl1-mesa-glx : Conflicts: libgl1 which is a virtual package.
 libglapi-mesa-lts-utopic : Conflicts: libglapi-mesa but 10.1.3-0ubuntu0.3 is to be installed.

Anyone has a suggestion for these errors? Should I try a new reinstall and hope for the best or is it a known error?

edit retag flag offensive close merge delete

Comments

This looks like a duplicate: http://answers.ros.org/question/20282...

tfoote gravatar imagetfoote ( 2015-02-23 15:37:08 -0500 )edit

Using APT, I'm getting the same error as the OP, and the error's next line says: ros-indigo-desktop-full depends on ros-indigo-desktop I'm running my Ubuntu on a MacBook Pro 15" Retina 2014.
@tfoote: the details of that question are different.

Nap gravatar imageNap ( 2015-02-23 23:53:02 -0500 )edit

I tried installing each of the dependencies mentioned but received the following in my terminal: libcheese-gtk23 is already the newest version. libcheese-gtk23 set to manually installed. 0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

Nap gravatar imageNap ( 2015-02-24 00:28:06 -0500 )edit

I tried building from Source but after issuing the rosdep install ... command, it returned:

Nap gravatar imageNap ( 2015-02-24 00:42:58 -0500 )edit

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. ERROR: the following rosdeps failed to install apt: command [sudo -H apt-get install -y libfltk1.1-dev] failed

Nap gravatar imageNap ( 2015-02-24 00:43:31 -0500 )edit

When I tried to install libclutter-gtk-1.0-0 I get: libclutter-gtk-1.0-0 is already the newest version. 0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

Nap gravatar imageNap ( 2015-02-24 00:54:22 -0500 )edit

I believe the underlying issue is that the lts-utopic mesa drivers are conflicting with the standard mesa drivers. Which is the same issue as the other question. Can you see what information you can get from: sudo apt-get install -o Debug::pkgProblemResolver=yes <package>

tfoote gravatar imagetfoote ( 2015-02-24 01:59:27 -0500 )edit

I need to post this in an answer field (not enough room in the comments section, or formatting options).

Nap gravatar imageNap ( 2015-02-24 04:06:57 -0500 )edit

5 Answers

Sort by » oldest newest most voted
8

answered 2015-02-24 14:09:20 -0500

demmeln gravatar image

updated 2016-08-21 23:55:03 -0500

I believe I recently fixed this issue by installing the LTS enablement stack related -dev packages:

sudo apt-get install xserver-xorg-dev-lts-utopic mesa-common-dev-lts-utopic libxatracker-dev-lts-utopic libopenvg1-mesa-dev-lts-utopic libgles2-mesa-dev-lts-utopic libgles1-mesa-dev-lts-utopic libgl1-mesa-dev-lts-utopic libgbm-dev-lts-utopic libegl1-mesa-dev-lts-utopic

Edit: I guess if this is the case then it would be a bug with Ubuntu. I.e. it tries to satisfy some dependency for some -dev package with one that conflicts with the already installed -utopic packages.

Edit2: I used something similar to upgrade to 14.04.3 HWE (the first set of packages is from the upgrade guide, the second are the -dev packages to prevent ros packages from uninstalling):

sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid libgl1-mesa-glx-lts-vivid libglapi-mesa-lts-vivid libgles1-mesa-lts-vivid libegl1-mesa-lts-vivid           xserver-xorg-dev-lts-vivid mesa-common-dev-lts-vivid libxatracker-dev-lts-vivid libgles2-mesa-dev-lts-vivid libgles1-mesa-dev-lts-vivid libgl1-mesa-dev-lts-vivid libgbm-dev-lts-vivid libegl1-mesa-dev-lts-vivid

Edit3: For upgrading to 14.04.5 HWE (I skipped 14.04.4) the same approach seems to work on my machine:

sudo apt-get install --install-recommends linux-generic-lts-xenial xserver-xorg-core-lts-xenial xserver-xorg-lts-xenial xserver-xorg-video-all-lts-xenial xserver-xorg-input-all-lts-xenial libwayland-egl1-mesa-lts-xenial           xserver-xorg-dev-lts-xenial mesa-common-dev-lts-xenial libxatracker-dev-lts-xenial libgles2-mesa-dev-lts-xenial libgles1-mesa-dev-lts-xenial libgl1-mesa-dev-lts-xenial libgbm-dev-lts-xenial libegl1-mesa-dev-lts-xenial
edit flag offensive delete link more

Comments

Oh, it works. I just checked it on a VM, but dont think its gonna behave differently on my target machine.

NLZ gravatar imageNLZ ( 2015-02-24 14:40:05 -0500 )edit
1

I have updated the ROS wiki with your fix http://wiki.ros.org/indigo/Installati...

Hopefully this will save any new users who are trying ROS on a fresh trusty install, until this dependency issue is resolved upstream.

paulbovbel gravatar imagepaulbovbel ( 2015-02-26 09:44:39 -0500 )edit

Thnx Demmeln. I'm still going down the build from source path, and it did go a lot further, but I'm get a similar error still, but this time for Unity-Control Center: The following packages have unmet dependencies: unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going

Nap gravatar imageNap ( 2015-02-27 03:18:32 -0500 )edit

to be installed Depends: libcheese7 (>= 3.0.1) but it is not going to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Nap gravatar imageNap ( 2015-02-27 03:19:10 -0500 )edit

ERROR: the following rosdeps failed to install apt: command [sudo -H apt-get install -y libgl1-mesa-dev] failed

Nap gravatar imageNap ( 2015-02-27 03:19:50 -0500 )edit

Perhaps there is another package that needs to be added to your list?

Nap gravatar imageNap ( 2015-02-27 03:20:15 -0500 )edit

I have been trying to make this work but I'm getting Unable to locate package, anyone knows how to solve this ? I'm new to Linux, hope this isn't a dumb question. Ty

Spyri gravatar imageSpyri ( 2015-03-06 20:10:36 -0500 )edit

I believe this is an issue upstream here: https://bugs.launchpad.net/ubuntu/+so...

tfoote gravatar imagetfoote ( 2015-03-11 02:32:42 -0500 )edit
0

answered 2015-02-23 12:43:23 -0500

I just installed fresh 14.04.2 and I'm getting exactly the same errors...

Any suggestions?

edit flag offensive delete link more

Comments

As Come mentioned, run this command: sudo apt-get install libgl1-mesa-dev-lts-utopic

It worked for me.

Andlat gravatar imageAndlat ( 2015-03-14 20:21:29 -0500 )edit

The accepted answer (by demmeln) fixed it all up for me, which includes libgl1-mesa-dev-lts-utopic in the list of packages to install.

Nap gravatar imageNap ( 2015-04-20 07:59:30 -0500 )edit

The accepted answer worked for me but then I could not reboot the computer. And it happened in more than 1 computer.

Javier V. Gómez gravatar imageJavier V. Gómez ( 2015-05-12 05:00:18 -0500 )edit
0

answered 2015-03-06 00:26:45 -0500

Corne gravatar image

I have fixed it by installing the additional package

sudo apt-get install libgl1-mesa-dev-lts-utopic

edit flag offensive delete link more

Comments

Thanks this worked for me installing on a fresh 14.04.2 64bit...

Atom gravatar imageAtom ( 2015-03-10 17:51:56 -0500 )edit

Added to the ROS wiki.

Coconut gravatar imageCoconut ( 2015-03-10 18:50:12 -0500 )edit

FWIW, This did not work for me. I'm running up to date 14.04.2.

Dereck gravatar imageDereck ( 2015-04-21 11:54:07 -0500 )edit

Try installing all the other packages that demmeln mentions in the accepted answer. They got it going for me.

Nap gravatar imageNap ( 2015-04-21 22:21:43 -0500 )edit

This just gives me similar errors. Depends: libegl1-mesa-lts-utopic (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed

Cerin gravatar imageCerin ( 2016-09-15 15:32:29 -0500 )edit
-1

answered 2015-02-24 04:09:52 -0500

Nap gravatar image

The output for libfltk1.1-dev is below. None of the other packages mentioned produce any actual warnings.

nap@rmbp:[20:04]:~$ sudo apt-get install -o Debug::pkgProblemResolver=yes libfltk1.1-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 3
Starting 2 pkgProblemResolver with broken count: 3
Investigating (0) libgl1-mesa-dri-lts-utopic [ amd64 ] < 10.3.2-0ubuntu1~trusty2 > ( libs )
Broken libgl1-mesa-dri-lts-utopic:amd64 Conflicts on libgl1-mesa-dri [ amd64 ] < none -> 10.1.3-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-dri:amd64 31 as a solution to libgl1-mesa-dri-lts-utopic:amd64 35
  Added libgl1-mesa-dri:amd64 to the remove list
  Conflicts//Breaks against version 10.1.0-4ubuntu5 for libgl1-mesa-dri but that is not InstVer, ignoring
  Fixing libgl1-mesa-dri-lts-utopic:amd64 via keep of libgl1-mesa-dri:amd64
Investigating (0) libglapi-mesa-lts-utopic [ amd64 ] < 10.3.2-0ubuntu1~trusty2 > ( libs )
Broken libglapi-mesa-lts-utopic:amd64 Conflicts on libglapi-mesa [ amd64 ] < none -> 10.1.3-0ubuntu0.3 > ( libs )
  Considering libglapi-mesa:amd64 21 as a solution to libglapi-mesa-lts-utopic:amd64 29
  Added libglapi-mesa:amd64 to the remove list
  Conflicts//Breaks against version 10.1.0-4ubuntu5 for libglapi-mesa but that is not InstVer, ignoring
  Fixing libglapi-mesa-lts-utopic:amd64 via keep of libglapi-mesa:amd64
Investigating (0) xserver-xorg-lts-utopic [ amd64 ] < 1:7.7+7ubuntu2~trusty1 > ( x11 )
Broken xserver-xorg-lts-utopic:amd64 Conflicts on libgl1-mesa-glx [ amd64 ] < none -> 10.1.3-0ubuntu0.3 > ( libs ) (>= 0~)
  Considering libgl1-mesa-glx:amd64 61 as a solution to xserver-xorg-lts-utopic:amd64 0
  Removing xserver-xorg-lts-utopic:amd64 rather than change libgl1-mesa-glx:amd64
Investigating (1) libgl1-mesa-glx [ amd64 ] < none -> 10.1.3-0ubuntu0.3 > ( libs )
Broken libgl1-mesa-glx:amd64 Depends on libglapi-mesa [ amd64 ] < none -> 10.1.3-0ubuntu0.3 > ( libs ) (= 10.1.3-0ubuntu0.3)
  Considering libglapi-mesa:amd64 21 as a solution to libgl1-mesa-glx:amd64 61
  Holding Back libgl1-mesa-glx:amd64 rather than change libglapi-mesa:amd64
Investigating (1) libwebkitgtk-3.0-0 [ amd64 ] < 2.4.7-1~ubuntu1 > ( libs )
Broken libwebkitgtk-3.0-0:amd64 Depends on libgl1-mesa-glx [ amd64 ] < none -> 10.1.3-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-glx:amd64 61 as a solution to libwebkitgtk-3.0-0:amd64 36
  Try Installing libgl1-mesa-glx [ amd64 ] < none -> 10.1.3-0ubuntu0.3 > ( libs ) before changing libwebkitgtk-3.0-0:amd64
Investigating (1) libgl1-mesa-dri-lts-utopic [ amd64 ] < 10.3.2-0ubuntu1~trusty2 > ( libs )
Broken libgl1-mesa-dri-lts-utopic:amd64 Conflicts on libgl1-mesa-dri [ amd64 ] < none -> 10.1.3-0ubuntu0.3 > ( libs )
  Considering libgl1-mesa-dri:amd64 31 as a solution to libgl1-mesa-dri-lts-utopic:amd64 35
  Added libgl1-mesa-dri:amd64 to the remove list
  Conflicts//Breaks against version 10.1.0-4ubuntu5 for libgl1-mesa-dri but that is not InstVer, ignoring
  Fixing libgl1-mesa-dri-lts-utopic:amd64 via keep of libgl1-mesa-dri:amd64
Investigating (1) libglapi-mesa-lts-utopic [ amd64 ] < 10.3.2-0ubuntu1~trusty2 > ( libs )
Broken libglapi-mesa-lts-utopic:amd64 Conflicts on libglapi-mesa [ amd64 ] < none -> 10.1.3-0ubuntu0.3 > ( libs )
  Considering libglapi-mesa:amd64 21 as a solution to libglapi-mesa-lts-utopic:amd64 29
  Added libglapi-mesa:amd64 to the remove list
  Conflicts//Breaks against version 10.1.0-4ubuntu5 for libglapi-mesa but that is not InstVer, ignoring
  Fixing libglapi-mesa-lts-utopic:amd64 via keep of libglapi-mesa:amd64
Investigating (1) xorg [ amd64 ] < 1:7.7+1ubuntu8.1 > ( x11 )
Broken xorg:amd64 Depends on xserver-xorg [ amd64 ] < none -> 1:7.7+1ubuntu8.1 > ( x11 ) (>= 1:7.7+1ubuntu8.1)
  Considering xserver-xorg:amd64 1 as a solution to xorg:amd64 1
  Try Installing xserver-xorg [ amd64 ] < none -> 1:7.7+1ubuntu8.1 > ( x11 ) before changing ...
(more)
edit flag offensive delete link more
-1

answered 2015-03-11 08:01:39 -0500

sergi23 gravatar image

The following packages have unmet dependencies:

libgl1-mesa-dev : Conflicts: libgl-dev

               Conflicts: libgl1-mesa-dri-dev

libgl1-mesa-dev-lts-utopic : Depends: mesa-common-dev-lts-utopic (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed

Depends: libgl1-mesa-glx-lts-utopic (= 10.3.2-0ubuntu1~trusty2) but it is not going to be installed

Conflicts: libgl-dev

Conflicts: libgl1-mesa-dev

Conflicts: libgl1-mesa-dri-dev

ros-indigo-rviz : Depends: libyaml-cpp-dev but it is not going to be installed

xserver-xorg : Conflicts: xorg-renamed-package

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

i get this error too don't know how to correct it, if someone have an idea!

edit flag offensive delete link more

Comments

have you tried apt-get -f install ?

demmeln gravatar imagedemmeln ( 2015-03-13 11:43:11 -0500 )edit

Yes tried this but couldnt solve it, finally i get ubuntu 13.10 Saucy and I'm working with it for indigo, because i didnt find any solution for 14.04.2. Thank you

sergi23 gravatar imagesergi23 ( 2015-03-13 12:25:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-02-23 09:46:47 -0500

Seen: 43,713 times

Last updated: Aug 21 '16