OctoMap not publishing anything ?? [closed]

asked 2015-02-14 14:07:00 -0600

shehrozeb37 gravatar image

Hi I am trying to convert PointCloud2 into OctoMap. I publish the point cloud (from a ply file) on topic 'cloud_in' with frame_id set to 'base_link'. When I run rostopic echo cloud_in I can see all the messages published. I then launch the octomap_server node using the roslaunch command. The code of the launch file is below.

<launch>

<!-- Octomap Server -->
<node pkg="octomap_server" type="octomap_server_node" name="octomap">
    <param name="resolution" value="0.05" />

    <param name="frame_id" type="string" value="base_link" />

    <param name="max_sensor_range" value="20.0" />

    <param name="latch" value="false" />
    <remap from="cloud_in" to="occupied_cells_vis" />

</node>

</launch>

but nothing is displayed in the MarkerArray in Rviz. I have tried changing the topic of MarkerArray to occupied_cells_vis because it automatically adds the _array at the end. I have also tried occupied_cells_vis_array but still it blank

What am I doing wrong here??

Cheers

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-01-11 20:08:42.955934