Depends: ... but it is not installable [closed]

asked 2015-02-13 11:13:44 -0500

Szajo gravatar image

updated 2015-02-16 04:36:18 -0500

BennyRe gravatar image


I tried to install hokuyo_node, but i have this problem:

david@david:~$ sudo apt-get install ros-hydro-hokuyo-node

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:
ros-hydro-hokuyo-node : Depends: libboost-thread1.49.0 (>= 1.49.0-1) but it is not installable

E: Unable to correct problems, you have held broken packages.

I tried to fix it using the commands:

$ sudo apt-get update

$ sudo apt-get upgrade 

$ sudo apt-get -f install

But I still have the problem

Thank you

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-01-11 20:11:25.536986