Ask Your Question
2

Unmet dependencies in apt-get install ros-hydro-desktop-full

asked 2013-12-03 02:39:32 -0500

urthkakao gravatar image

updated 2014-01-28 17:18:42 -0500

ngrennan gravatar image

Hi,

I am trying to install Hydro on Ubuntu 12.04. When I enter sudo apt-get install ros-hydro-desktop-full, I am getting the following error messages.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-hydro-desktop-full : Depends: ros-hydro-desktop but it is not going to be installed
                          Depends: ros-hydro-mobile but it is not going to be installed
                          Depends: ros-hydro-perception but it is not going to be installed
                          Depends: ros-hydro-simulators but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried apt-get update, apt-get upgrade, and apt-get -f install, but I am still getting the same error.

Can anybody know how to solve this problem?

When I use aptitude instead I got the following result: (it is really long..)

The following NEW packages will be installed:
  collada-dom-dev{a} collada-dom2.4-dp-base{a} collada-dom2.4-dp-dev{a} 
  docgenerator{a} ffmpeg{a} fltk1.3-doc{a} fluid{a} gazebo{a} 
  generatorrunner{a} hddtemp{a} libapiextractor-dev{a} libapiextractor0.10{a} 
  libasound2-dev{ab} libassimp-dev{a} libassimp2{a} libatk1.0-dev{a} 
  libav-tools{a} libavcodec-dev{a} libavcodec-extra-53{ab} libavdevice53{a} 
  libavfilter2{a} libavformat-dev{a} libavformat-extra-53{ab} 
  libavutil-dev{a} libavutil-extra-51{ab} libbullet{a} libbullet-dev{a} 
  libcaca-dev{a} libcairo2-dev{ab} libcegui-mk2-0.7.5{a} libcegui-mk2-dev{a} 
  libcppunit-1.12-1{a} libcppunit-dev{a} libcurl4-openssl-dev{a} 
  libdevil-dev{a} libdevil1c2{a} libflann-dev{a} libflann1{a} 
  libfltk-cairo1.3{a} libfltk-forms1.3{a} libfltk-gl1.3{a} 
  libfltk-images1.3{a} libfltk1.1-dev{ab} libfltk1.3{a} libfltk1.3-dev{ab} 
  libfontconfig1-dev{ab} libfreeimage-dev{a} libfreeimage3{a} 
  libfreetype6-dev{ab} libgdk-pixbuf2.0-dev{a} libgenrunner-dev{a} 
  libgenrunner0.6{a} libgeos-3.2.2{a} libgeos-c1{a} libgl2ps-dev{a} 
  libgl2ps0{a} libglib2.0-dev{ab} libgnutls-dev{ab} libgtk2.0-dev{a} 
  libhdf5-serial-1.8.4{a} libidn11-dev{a} libjasper-dev{a} libjpeg-dev{a} 
  libjpeg-turbo8-dev{ab} libjpeg8-dev{a} libjs-sphinxdoc{a} 
  libjs-underscore{a} liblcms1-dev{a} liblodo3.0{a} liblua5.1-0-dev{a} 
  libmng-dev{a} libnetcdf-dev{a} libnetcdf6{a} libodbc1{a} libogg-dev{a} 
  libogre-1.7.4{a} libogre-dev{a} libois-1.3.0{a} libopencv-core2.3{a} 
  libopencv-highgui2.3{a} libopencv-imgproc2.3{a} libopenjpeg2{a} 
  libopenni-dev{a} libopenni-sensor-primesense0{a} libopenni0{a} 
  libpango1.0-dev{ab} libpcl-1.7-all{a} libpcl-1.7-all-dev{a} 
  libpcl-1.7-bin{a} libpcl-1.7-doc{a} libpcl-apps-1.7{a} 
  libpcl-apps-1.7-dev{a} libpcl-common-1.7{a} libpcl-common-1.7-dev{a} 
  libpcl-features-1.7{a} libpcl-features-1.7-dev{a} libpcl-filters-1.7{a} 
  libpcl-filters-1.7-dev{a} libpcl-geometry-1.7-dev{a} libpcl-io-1.7{a} 
  libpcl-io-1.7-dev{a} libpcl-kdtree-1.7{a} libpcl-kdtree-1.7-dev{a} 
  libpcl-keypoints-1.7{a} libpcl-keypoints-1.7-dev{a} libpcl-octree-1.7{a} 
  libpcl-octree-1.7-dev{a} libpcl-outofcore-1.7{a} 
  libpcl-outofcore-1.7-dev{a} libpcl-people-1.7{a} libpcl-people-1.7-dev{a} 
  libpcl-recognition-1.7{a} libpcl-recognition-1.7-dev{a} 
  libpcl-registration-1.7{a} libpcl-registration-1.7-dev{a} 
  libpcl-sample-consensus-1.7{a} libpcl-sample-consensus-1.7-dev{a} 
  libpcl-search-1.7{a} libpcl-search-1.7-dev{a} libpcl-segmentation-1.7{a} 
  libpcl-segmentation-1.7-dev{a} libpcl-surface-1.7 ...
(more)
edit retag flag offensive close merge delete

Comments

Try aptitude instead of apt-get and post the suggestions it gives here.

dornhege gravatar imagedornhege ( 2013-12-03 03:56:26 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
4

answered 2013-12-03 08:58:09 -0500

astrokenny gravatar image

updated 2013-12-03 09:00:37 -0500

I encountered the same problem. For me, the problem was that an upgrade to ps-engine depended on a version of openni-dev that apparently more recent than what is available in 12.04. To fix it I ran aptitude as follows:

$ sudo aptitude install ros-hydro-desktop-full
...
The following packages have unmet dependencies:
 ps-engine : Depends: openni-dev (>= 1.5.2.23~precise) but 1.3.2.1-4+precise2 is
installed.
The following actions will resolve these dependencies:

      Keep the following packages at their current version:
  [...lists 39 ROS and PCL packages that are not (and will not be) installed...]
Accept this solution? [Y/n/q/?]

Clearly that isn't desirable, so do not accept that solution (hit 'n <enter>' in response to the question above). Then aptitude gives an alternate solution:

The following actions will resolve these dependencies:

     Install the following packages:           
1)     ps-engine [5.0.3.3-3+precise1 (precise)]

Accept this solution? [Y/n/q/?]

That solution installs an earlier version of ps-engine, which can have it's dependencies met, so it works. Accept it and let aptitude do its work; that should fix your problem.

Hopefully a version of openni-dev which is compatible with the latest ps-engine will be added to the apt repositories soon...

edit flag offensive delete link more

Comments

Thanks. It helped to realize that I had strange dependency problem (many of them), so I had to completely remove ubuntu, and reinstall.

urthkakao gravatar imageurthkakao ( 2013-12-08 22:48:48 -0500 )edit
1

answered 2013-12-03 06:15:47 -0500

Jtheletter gravatar image

Hi, I just ran into this same problem yesterday but was able to eventually get Hydro installed.

I had a number of dependencies which were a minor revision beyond what was compatible with Hydro, I used aptitude to correct them. You can use aptitude to install the missing packages until you get to the point where it reports no changes will be made, at that point if you select 'no' for the proposed configuration aptitude should suggest alternative dependencies.

It can be helpful to walk down the dependency tree to find the unmet/conflicting dependencies using apt-get.

e.g. if apt-get install ros-hydro-desktop-full fails, try apt-get install for the first unmet dependency listed, in this case that would be ros-hydro-desktop. Continue trying to apt-get install the first unmet dependency listed until you finally reach the underlying conflict, at that point aptitude can be useful for suggesting an alternative.

edit flag offensive delete link more
0

answered 2014-02-18 19:40:43 -0500

Adnan Munawar gravatar image

In my case I had to install libbullet (2.81-2ppa1~precise). I got to that by running

sudo apt-get install ros-hydro-dektop-full

and then kept on running apt-get for the unmet dependency till I came to libbullet..

That I installed from package manager and seems that openrave installation has some older version of libbullet that prevents that install of hydro full in the first place. After doing the install from package manager, I got to install the full desktop hydro.

edit flag offensive delete link more

Comments

could yu explain the process once again please

amartya18x gravatar imageamartya18x ( 2014-05-21 02:54:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-12-03 02:39:32 -0500

Seen: 9,044 times

Last updated: Feb 18 '14