Ask Your Question
0

unmet dependencies while installing ROS Fuerte on Ubuntu 12.04 64-bit

asked 2012-09-18 00:24:53 -0500

whiterose gravatar image

Hi all,

I have recently upgraded to Ubuntu 12.04, and naturally tried to upgrade to ROS Fuerte. My laptop has the following specifications:

Memory: 1.9 GiB Processor: Intel® Core™2 Duo CPU T8100 @ 2.10GHz × 2 Graphics: Intel® 965GM
OS Type: 64-bit

I have been installing-removing-installing-removing ROS Fuerte again and again and keep on getting the following error.

Selecting previously unselected package ros-fuerte-desktop-full. Unpacking ros-fuerte-desktop-full (from .../ros-fuerte-desktop-full_1.0.0-s1347207966~precise_amd64.deb) ... Errors were encountered while processing: /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

and also the fact that Ubuntu reported error message saying

'Error: Broken count>0' This usually means that your installed packages have unmet dependencies

I upgraded libassimp via synaptic, so now I have libassimp2-d-dev, libassimp3.0 ...

Then, I tried

sudo apt-get -f install

I get the following messages.

Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were automatically installed and are no longer required: kdesudo update-manager-kde Use 'apt-get autoremove' to remove them. The following extra packages will be installed: libassimp-dev The following NEW packages will be installed: libassimp-dev 0 upgraded, 1 newly installed, 0 to remove and 132 not upgraded. 5 not fully installed or removed. Need to get 0 B/94.4 kB of archives. After this operation, 470 kB of additional disk space will be used. Do you want to continue [Y/n]? Y (Reading database ... 413855 files and directories currently installed.) Unpacking libassimp-dev (from .../libassimp-dev_2.0.863+dfsg-2_amd64.deb) ... dpkg: error processing /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb (--unpack): trying to overwrite '/usr/include/assimp/Compiler/poppack1.h', which is also in package libassimp3.0-r1264-dev 3.0.1264.10-ubuntu1~precise1 No apport report written because MaxReports is reached already Errors were encountered while processing: /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

I have read a few threads on unmet dependencies, still, I'm not sure what to fix.

Thread 1: http://answers.ros.org/question/43369/unmet-dependencies-for-fuerte-desktop-full-on-1204/

Thread 2: http://answers.ros.org/question/42596/unmet-dependency-on-eigen-for-vision-opencv-now-cant-install-or-upgrade-any-fuerte-packages/

Anyhow, ROS is running whenever I call roscore, but I will not be able to create overlay, since I cannot do this (synaptic will prompt me to remove some ros related packages like ros-desktop-full etc):

sudo apt-get install python-rosinstall python-rosdep

in which I will get the following messages

The following packages have unmet dependencies: python-rosinstall : Depends: mercurial but it is not going to be installed Depends: bzr but it is not going to be installed Depends: python-vcstools but it is not going to be installed ros-fuerte-robot-model : Depends: libassimp-dev but it is not going to be installed ros-fuerte-visualization : Depends: libassimp-dev but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Any ideas?

edit retag flag offensive close merge delete

Comments

Was this the solution?! I have exactly the same problem. I upgraded my Ubuntu from 10.04 to 12.04 and Fuerte will not install due to the same errors as above.

TurtleBot_Fan gravatar imageTurtleBot_Fan ( 2012-09-19 17:02:41 -0500 )edit

I have not yet found a solution :(.. tried uninstalling 'libassimp2-dev', and then installed 'libassimp2' and then unistalling it, basically i tried every possible libassimp in synaptic.....

whiterose gravatar imagewhiterose ( 2012-09-21 23:46:24 -0500 )edit

solved by removing libassimp3.0 and installed libassimp-dev... allenh1's solution was right.

whiterose gravatar imagewhiterose ( 2012-09-25 03:16:31 -0500 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2012-09-18 03:28:54 -0500

allenh1 gravatar image

updated 2012-09-18 03:30:42 -0500

Try removing libassimp-dev and the other problems you are having trouble with. You likely have a newer version installed.

If this doesn't work, start the system install over. To do this without losing any data, I recommend you install as you usually would, but DO NOT format the drive. Doing so will erase your data. By not formatting the drive, you can keep the data but override the operating system files.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-18 00:24:53 -0500

Seen: 1,689 times

Last updated: Sep 18 '12