Ask Your Question
0

Make use of 3rd party packages.

asked 2015-02-11 06:22:12 -0500

215 gravatar image

updated 2015-02-11 07:01:41 -0500

gvdhoorn gravatar image

Hi guys.. I am a bit new with ROS, and I am struggling with making use of a 3rd party package. namely flir_ptu_driver.

I am not sure how to even make use of it. I tried creating a workspace, and git clone it into the SRC file. but when i performed catkin_make and catkin_make install I received error messages saying

add the installation prefix of "serial" to CMAKE_PREFIX_PATH or set "serial_DIR" to a directory containing one of the above files. if "serial" provides a separate development packages SDK, be sure it has been installed.

I am not sure what it means but hope some you guys could help guide through the setup phase of this ros stacks, or just in general.

I found one in the tutorial, but it seemed like it was more focused on a certain kind of stack, and not an "all-purpose" stack installation.

edit retag flag offensive close merge delete

Comments

Have you followed the introductory tutorials? They should give you at least some more insight into how things work with pkgs.

gvdhoorn gravatar imagegvdhoorn ( 2015-02-11 06:31:06 -0500 )edit

I understand your concern.. yes I have been followed the introductory tutorial, and I know the mistake must be something very silly.. i've tried so many different things.. That i think i might have mixed them together.. This how my workspace is here: http://tinyurl.com/q9v9w92

215 gravatar image215 ( 2015-02-11 06:37:39 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-02-11 06:59:28 -0500

gvdhoorn gravatar image

The error you are seeing tells you that flir_ptu_driver cannot find one of its dependencies, in this case the serial package.

Depending on what you actually intend to do, you have two options:

  1. install the binary release of flir_ptu_driver: something like sudo apt-get install ros-DISTRO-flir-ptu-driver should work. All dependencies should also be automatically installed for you this way.
  2. make sure you have all dependencies installed before trying to catkin_make the sources: you can do this with rosdep, like so (see also the rosdep documentation):

    rosdep install --from-paths /path/to/your/catkin_ws/src --ignore-src
    

    after you have sourced the appropriate setup.bash for your ROS distro.

    Invoking catkin_make should now succeed (provided flir_pty_driver declares all its dependencies correctly).

edit flag offensive delete link more

Comments

installed the serial dependencies , and it works now..

215 gravatar image215 ( 2015-02-11 07:39:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-02-11 06:22:12 -0500

Seen: 440 times

Last updated: Feb 11 '15