Ask Your Question
0

unmet dependencies while installing Ros on Ubuntu [closed]

asked 2015-02-08 10:26:37 -0500

Dayire gravatar image

updated 2015-05-31 08:02:06 -0500

Hello,

I'm using Ubuntu 13.04 (Raring) x64 with a virtual machine

I run:

  sudo apt-get install ros-hydro-desktop-full  

I get:

  
Reading package lists... Done
Building dependency tree 
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-hydro-desktop-full : Depends: ros-hydro-desktop but it is not going to be installed Depends: ros-hydro-mobile but it is not going to be installed Depends: ros-hydro-perception but it is not going to be installed Depends: ros-hydro-simulators but it is not going to be installed E: Unable to correct problems, you have held broken packages.

I have followed every step on the ros wiki (from allowing "restricted," "universe," and "multiverse." to updating the index)

I have also checked other solutions and many of them suggested using aptitude, still I couldn't use aptitude since I had errors while installing its package.

If you need more details let me know.

Help me !

Thanks :)

[UPDATE]

It's just that ROS Hydro didn't work out with ubuntu 13.04 due to its instability I guess. I recommend you guys, if you have this problem, to switch to a more stable ubuntu distribution (12.04 LTS worked just fine with me)

Thanks :)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Dayire
close date 2015-05-31 08:03:17.621632

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-02-11 21:02:36 -0500

tfoote gravatar image

updated 2015-05-31 16:22:26 -0500

You have a package conflict at a lower level. You'll need to recursively try each dependency which complains until you find the lowest level conflict and resolve that.

apt-get is surprisingly unhelpful doing this. Each time you get an error like that try to explicitly install each of the Depends entries, until you find the problem when it gives a useful error message.

You can use sudo apt-get install -o Debug::pkgProblemResolver=yes <package> to get more details from apt.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-02-08 10:26:37 -0500

Seen: 235 times

Last updated: May 31 '15