ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Rosed Cmakelist.txt?

asked 2015-02-02 09:28:14 -0500

215 gravatar image

updated 2015-02-03 13:47:56 -0500

I am learning ROS at the moment using the tutorial available here on this page. I am so far, but for some reason not come past opening the CMakeList.txt using rosed roscpp

it says that it cannot find the package eventhough i am inside the folder. I've changes the package.xml... I changed using nano, and tried to make a rosmsg show of the num.msg i've created at the begining, but the output is not as should be.. What is wrong here....

I not even able to <tab><tab> my way to the folder beginner_tutorials ..... using rosmsg show

The output I get when i rosmsg show beginner_tutorials/Num is

Unable to load msg [beginner_tutorials/Num]: Cannot locate message [Num]: unknown package [beginner_tutorials] on search path [{'rosconsole': ['/opt/ros/indigo/share/rosconsole/msg'], 'catkin': ['/opt/ros/indigo/share/catkin/msg'], 'angles': ['/opt/ros/indigo/share/angles/msg'], 'image_view': ['/opt/ros/indigo/share/image_view/msg'], 'carrot_planner': ['/opt/ros/indigo/share/carrot_planner/msg'], 'urdf': ['/opt/ros/indigo/share/urdf/msg'], 'rosgraph': ['/opt/ros/indigo/share/rosgraph/msg'], 'rqt_py_console': ['/opt/ros/indigo/share/rqt_py_console/msg'], 'nodelet_topic_tools': ['/opt/ros/indigo/share/nodelet_topic_tools/msg'], 'rqt_graph': ['/opt/ros/indigo/share/rqt_graph/msg'], 'rotate_recovery': ['/opt/ros/indigo/share/rotate_recovery/msg'], 'theora_image_transport': ['/opt/ros/indigo/share/theora_image_transport/msg'], 'rocon_python_comms': ['/opt/ros/indigo/share/rocon_python_comms/msg'], 'qt_gui': ['/opt/ros/indigo/share/qt_gui/msg'], 'filters': ['/opt/ros/indigo/share/filters/msg'], 'ecl_exceptions': ['/opt/ros/indigo/share/ecl_exceptions/msg'], 'navfn': ['/opt/ros/indigo/share/navfn/msg'], 'dwa_local_planner': ['/opt/ros/indigo/share/dwa_local_planner/msg'], 'rosgraph_msgs': ['/opt/ros/indigo/share/rosgraph_msgs/msg'], 'smclib': ['/opt/ros/indigo/share/smclib/msg'], 'ecl_devices': ['/opt/ros/indigo/share/ecl_devices/msg'], 'rocon_gateway_utils': ['/opt/ros/indigo/share/rocon_gateway_utils/msg'], 'roscpp_serialization': ['/opt/ros/indigo/share/roscpp_serialization/msg'], 'rqt_rviz': ['/opt/ros/indigo/share/rqt_rviz/msg'], 'rosbuild': ['/opt/ros/indigo/share/rosbuild/msg'], 'qt_gui_cpp': ['/opt/ros/indigo/share/qt_gui_cpp/msg'], 'rosauth': ['/opt/ros/indigo/share/rosauth/msg'], 'tf': ['/opt/ros/indigo/share/tf/msg'], 'rqt_publisher': ['/opt/ros/indigo/share/rqt_publisher/msg'], 'roslang': ['/opt/ros/indigo/share/roslang/msg'], 'geometric_shapes': ['/opt/ros/indigo/share/geometric_shapes/msg'], 'kobuki_driver': ['/opt/ros/indigo/share/kobuki_driver/msg'], 'smach_ros': ['/opt/ros/indigo/share/smach_ros/msg'], 'genlisp': ['/opt/ros/indigo/share/genlisp/msg'], 'map_server': ['/opt/ros/indigo/share/map_server/msg'], 'interactive_markers': ['/opt/ros/indigo/share/interactive_markers/msg'], 'dynamic_reconfigure': ['/opt/ros/indigo/share/dynamic_reconfigure/msg'], 'ecl_containers': ['/opt/ros/indigo/share/ecl_containers/msg'], 'diagnostic_aggregator': ['/opt/ros/indigo/share/diagnostic_aggregator/msg'], 'ecl_license': ['/opt/ros/indigo/share/ecl_license/msg'], 'smart_battery_msgs': ['/opt/ros/indigo/share/smart_battery_msgs/msg'], 'robot_state_publisher': ['/opt/ros/indigo/share/robot_state_publisher/msg'], 'visualization_msgs': ['/opt/ros/indigo/share/visualization_msgs/msg'], 'diagnostic_updater': ['/opt/ros/indigo/share/diagnostic_updater/msg'], 'ecl_streams': ['/opt/ros/indigo/share/ecl_streams/msg'], 'resource_retriever': ['/opt/ros/indigo/share/resource_retriever/msg'], 'rqt_topic': ['/opt/ros/indigo/share/rqt_topic/msg'], 'smach': ['/opt/ros/indigo/share/smach/msg'], 'ecl_mpl': ['/opt/ros/indigo/share/ecl_mpl/msg'], 'stdr_parser': ['/opt/ros/indigo/share/stdr_parser/msg'], 'ecl_math': ['/opt/ros/indigo/share/ecl_math/msg'], 'rqt_action': ['/opt/ros/indigo/share/rqt_action/msg ...

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-02-02 14:54:00 -0500

marguedas gravatar image

Ok I'm not sur I got your problem:

Regarding rosed usage:
The main advantage of using rosed is that it uses the ROS package architecture. So you won't need to be inside any folder, you just need the environment variable $ROS_PACKAGE_PATH set. You set it by sourcing your workspace ("source ~/my_workspace/devel/setup.bash") and you shoud be able to use rosbash commands (roscd, rosls, rosed...).

rosed is working as follow : rosed PACKAGE_NAME FILENAME.
so if your run "rosed beginner_tutorial CMakeLists.txt" it will work
"rosed CMakeLists.txt" won't because CMakeLists.txt is a file, not a package.

If you are in the right folder you can just use "nano FILENAME", or "vim FILENAME" or any editor you use. rosed won't be of any value if you are already in the right package.

If your packages are not recognized:
source your workspace : "source ~/catkin_ws/devel/setup.bash"
update your package list : "rospack profile"
then you should be able to use rosbash commands : try "roscd beginner_tutorial"

If roscd works but rosmsg show doesn't work:
This means that your messages have not been generated. You need to build your package to generate the messages. To build your workspace you need to go in your workspace "cd ~/catkin_ws" and run "catking_make", you will see blue lines saying that your messages have been generated. Now rosmsg show should work

Hope this helps,

edit flag offensive delete link more


I tried them all, it doesn't work for my workspace.. would it help if i uploaded my workspace here?

215 gravatar image 215  ( 2015-02-03 13:49:03 -0500 )edit

catkin_ws doesn't appear in the console output you pasted. Are you sure your workspace has been sourced properly ? if you run "roscd" where do you end up ? in ~/catkin_ws/devel ? or /opt/ros/indigo ?

marguedas gravatar image marguedas  ( 2015-02-03 14:03:34 -0500 )edit

can you run the following ?

mkdir -p test_ws/src

cd test_ws/src


cp -r ~/catkin_ws/src/beginner_tutorials ./

cd ..


source ~/test_ws/devel/setup.bash

rosmsg show beginner_tutorials/Num

If you do it step by step there is no reason that this won't work

marguedas gravatar image marguedas  ( 2015-02-03 14:16:39 -0500 )edit

i don't why... but it works now..

215 gravatar image 215  ( 2015-02-03 14:57:47 -0500 )edit

ok cool, if you can vote to say that the question is solved this will allow to close it. Enjoy using ROS!

marguedas gravatar image marguedas  ( 2015-02-03 16:03:54 -0500 )edit

Question Tools

1 follower


Asked: 2015-02-02 09:28:14 -0500

Seen: 1,481 times

Last updated: Feb 03 '15