Ask Your Question
0

rosaria failed to connect to robot

asked 2015-01-28 05:34:19 -0500

RND gravatar image

Hi,

I want to use the RosAria package in order to send commands and interface with my robot. I have managed to successfully install and build this rosaria package and I have also tested it multiple times on simulation (by using MobileSim by MobileRobots).

Now I want to connect rosaria to the actual robot, Powerbot (a pioneer robot by Adept MobileRobots). I have successfully connected to the robot ONCE by running

rosrun rosaria RosAria _port:=/dev/ttyS0

Then I killed the node (^C) but when I tried to connect to it once again by re-running the same line (above), I got this error:

powerbot67@powerbot67-desktop:~/catkin_ws/src/rosaria$ rosrun rosaria RosAria
[ INFO] [1422444061.117081691]: RosAria: using port: [/dev/ttyS0]
Could not connect to simulator, connecting to robot through serial port /dev/ttyS0.
Syncing 0
No packet.
Syncing 0
No packet.
Trying to close possible old connection
Syncing 0
No packet.
Syncing 0
No packet.
 Robot may be connected but not open, trying to dislodge.
Syncing 0
No packet.
 Robot may be connected but not open, trying to dislodge.
Syncing 0
No packet.
Could not connect, no robot responding.
Failed to connect to robot.
[ERROR] [1422444067.613784823]: RosAria: ARIA could not connect to robot! (Check ~port parameter is correct, and permissions on port device.)
[FATAL] [1422444067.613882512]: RosAria: ROS node setup failed...

Now $USER is a member of the dialout group and I'm sure that the robot connection worked because: (a) I had connected to the robot through rosaria ONCE during the first time and (b) Before I installed rosaria I was working with the ARIA library directly and everything worked brilliantly.

In the error it is suggesting that I check that ~port parameter is correct, but I'm sure it is since I ran the same command previously.

Can somebody help me understand this please? Thanks!

edit retag flag offensive close merge delete

Comments

1

I have had this problem before a dozen times or so in the past year. A dirty fix that worked for me was to hit the reset button. Then power off the P3AT, and repower P3AT. I may have restarted my GUI computer in one of the steps to regain the connection.

Orso gravatar image Orso  ( 2015-01-28 08:04:20 -0500 )edit

It worked thanks!

RND gravatar image RND  ( 2015-01-29 02:26:33 -0500 )edit

remember that you will have to run the sudo chmod command every time you start the robot. You can define the sudo permissions in your launch file for ease.

AlexR gravatar image AlexR  ( 2015-01-29 02:46:17 -0500 )edit

can you mark it as an answer if it helped you. Thanks

AlexR gravatar image AlexR  ( 2015-01-29 02:48:40 -0500 )edit

The reset button for Powerbot is in the panel on the top-rear of the robot. Newer firmware it will make periodic beep to indicate that it is still expecting software communication but data has stopped (reset maybe required in this case). Sound can be turned on/off in firmware configuration though.

ReedHedges gravatar image ReedHedges  ( 2015-01-29 14:41:03 -0500 )edit

I cannot connect to pioneer robot using rosaria for several days. Although I was able to connect when I installed first. I tried powering of and turning power on of the robot but nothing changed. I also used restart button that also did not work. can any one help?

anirban gravatar image anirban  ( 2015-07-07 17:50:58 -0500 )edit

@anirban you can either follow the above comments, or check that the port you are using is valid. How are you connecting to rosaria?

RND gravatar image RND  ( 2015-07-08 02:29:07 -0500 )edit

I am connecting P3 using a serial cable. I am running the following command line $ rosrun rosaria RosAria _port:=/dev/ttyS2 S2 because I know this port worked well with aria example codes those are provided by Mobile robot. So basically I am using a USB serial converter to connect to the robot.

anirban gravatar image anirban  ( 2015-07-08 11:00:54 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-06-26 09:45:52 -0500

ReedHedges gravatar image

I'd first check that rosaria (or other software connected to the robot) isn't still running. This can prevent ARIA from resetting the connection. You can use the robot reset button as Orso says, but you shouldn't need to power off the whole robot. I'll put in a request to check/fix rosaria to make sure it always disconnects correctly on control-c.

If you were using a USB-serial converter that could potentially be a problem, though it doesn't look like that applies in your case (since you are using /dev/ttyS0).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-28 05:34:19 -0500

Seen: 1,747 times

Last updated: Jun 26 '15