Ask Your Question
0

move_base - missed desired rate

asked 2015-01-27 06:23:54 -0500

Federico gravatar image

Hi all,

I have a quite high level question. I'm currently trying to unplug the amcl node from the navigation stack and substitute it with a custom localization algorithm. Although I'm able to broadcast the transformation /map -> /odom with a high frequency (40Hz), I'm getting lots of errors such as

[ WARN] [1422360986.992858074, 13.073000000]: Control loop missed its desired rate of 10.0000Hz... the loop actually  took 0.8180 seconds

[ WARN] [1422360986.993048443, 13.073000000]: Map update loop missed its desired rate of 5.0000Hz... the loop actually  took 0.7770 seconds

as well as

[ERROR] [1422360988.321754058, 14.389000000]: Extrapolation Error: Lookup would require extrapolation into the future.  Requested time 13.881000000 but the latest data is at time 13.871000000, when looking up transform from frame [map] to frame [odom]

I was wondering what can cause such an error. The parameters in move_base are set so that the /amcl is not popping any of those warnings/errors.

Thanks and regards.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-01-27 11:06:02 -0500

David Lu gravatar image

The first errors come from the code taking longer to run than expected. It should be independent of the tf source.

edit flag offensive delete link more

Comments

Thanks David. Actually the update rate was too slow

Federico gravatar image Federico  ( 2015-02-03 15:52:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-27 06:23:54 -0500

Seen: 1,241 times

Last updated: Jan 27 '15