Ask Your Question
0

Problem detecting yaml-cpp in Hydro installation on MACOS Maveriks

asked 2015-01-22 09:03:22 -0600

Louise gravatar image

I'm trying to install ROS hydro on a macbook running Maveriks 10.9.5. The machine setup was cloned from a Lion machine which means I've had some problems with out-of-date dependencies and so on. My current problem comes when the system tries to build camera_calibration_parsers which fails with the error

CMake Error at CMakeLists.txt:16 (if): if given arguments:

"VERSION_GREATER" "0.5"

Unknown arguments specified

I _have_ managed to do a fresh-ish install of ROS on an iMAC running Maveriks 10.9.5 so I suspect the problem is legacy libraries on this machine. By comparing the two installations it looks like the build is failing to instantiate YAML_CPP_VERSION (and a bunch of other YAML based variables used by cmake)

The problem may be that yaml doesn't appear in /usr/local/lib/python2.7/site-packages but instead appears in /Library/Python/2.7/site-packages . I've uninstalled and reinstalled pip (making sure I have the correct version) but this doesn't seem to have made a difference. rosdep claims to be able to find everything it needs.

I'm a little wary of trying something drastic (like deleting the contents of /Library/Python/2.7/site-packages) so was wondering if anyone had a clearer idea why catkin_make_isolated can't detect yaml properly

edit retag flag offensive close merge delete

Comments

Isn't yaml-cpp a C++ library, not a Python library?

gvdhoorn gravatar imagegvdhoorn ( 2015-01-22 15:17:24 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2015-01-22 16:02:33 -0600

Louise gravatar image

Yes. I finally tracked the problem down to the fact that pkg-config was not installed in /usr/local/bin for some reason.

edit flag offensive delete link more

Comments

Can you please explain how did you fix the problem in detail?

filipposanfilippo gravatar imagefilipposanfilippo ( 2016-04-16 09:17:21 -0600 )edit
0

answered 2016-04-15 14:07:44 -0600

filipposanfilippo gravatar image

Hi, I am having a similar problem when installing ROS on OS X 10.11.4.

==> Processing catkin package: 'camera_calibration_parsers'

==> Building with env: '/Users/filipposanfilippo/ros_catkin_ws/install_isolated/env.sh' ==> cmake /Users/filipposanfilippo/ros_catkin_ws/src/image_common/camera_calibration_parsers -DCATKIN_DEVEL_PREFIX=/Users/filipposanfilippo/ros_catkin_ws/devel_isolated/camera_calibration_parsers -DCMAKE_INSTALL_PREFIX=/Users/filipposanfilippo/ros_catkin_ws/install_isolated -DCMAKE_BUILD_TYPE=Release -G Unix Makefiles in '/Users/filipposanfilippo/ros_catkin_ws/build_isolated/camera_calibration_parsers' -- Using CATKIN_DEVEL_PREFIX: /Users/filipposanfilippo/ros_catkin_ws/devel_isolated/camera_calibration_parsers -- Using CMAKE_PREFIX_PATH: /Users/filipposanfilippo/ros_catkin_ws/install_isolated -- This workspace overlays: /Users/filipposanfilippo/ros_catkin_ws/install_isolated -- Using PYTHON_EXECUTABLE: /usr/local/bin/python -- Using default Python package layout -- Using empy: /usr/local/lib/python2.7/site-packages/em.pyc -- Using CATKIN_ENABLE_TESTING: ON -- Call enable_testing() -- Using CATKIN_TEST_RESULTS_DIR: /Users/filipposanfilippo/ros_catkin_ws/build_isolated/camera_calibration_parsers/test_results -- Found gtest: gtests will be built -- Using Python nosetests: /opt/local/bin/nosetests-2.7 -- catkin 0.6.18 -- Boost version: 1.59.0 -- Found the following Boost libraries: -- filesystem -- python -- system -- Checking for module 'yaml-cpp' -- No package 'yaml-cpp' found CMake Error at CMakeLists.txt:26 (if): if given arguments:

"VERSION_GREATER" "0.5"

Unknown arguments specified

edit flag offensive delete link more

Comments

Cmake couldn't find yaml-cpp so the first part of ${YAML_CPP_VERSION} VERSION_GREATER 0.5 was empty, leading to the error message. Installing the library fixed the issue for me (sudo apt-get install libyaml-cpp-dev). Answer provided in this post.

Irin Thirdwater gravatar imageIrin Thirdwater ( 2019-09-03 07:30:04 -0600 )edit
0

answered 2015-05-20 17:30:07 -0600

natejgardner gravatar image

I'm encountering the same issue you are, but pkg-config is installed in /usr/local/bin for me. Any suggestions?

I found this link which gave some more insights, but still hasn't solved the problem.

https://github.com/ros-perception/ima...

edit flag offensive delete link more

Comments

Any luck finding a solution to this?

Omkar gravatar imageOmkar ( 2017-05-31 18:08:47 -0600 )edit

Cmake couldn't find yaml-cpp so the first part of ${YAML_CPP_VERSION} VERSION_GREATER 0.5 was empty, leading to the error message. Installing the library fixed the issue for me (sudo apt-get install libyaml-cpp-dev). Answer provided in this post.

Irin Thirdwater gravatar imageIrin Thirdwater ( 2019-09-03 07:29:53 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-22 09:03:22 -0600

Seen: 653 times

Last updated: Apr 15 '16